summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2012-12-19 22:48:09 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-20 15:25:10 +0100
commitdd1aa62cceff4aa9072d7933042480c20cfd07ef (patch)
tree6c2ad784d79fb0e94bfa29129982f36e252c9a22 /linux
parent2a27ad3d796720c6be79f13f0bc58e595584aa35 (diff)
downloadbuildroot-novena-dd1aa62cceff4aa9072d7933042480c20cfd07ef.tar.gz
buildroot-novena-dd1aa62cceff4aa9072d7933042480c20cfd07ef.zip
linux: Support multiple device tree build
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in5
-rw-r--r--linux/linux.mk7
2 files changed, 8 insertions, 4 deletions
diff --git a/linux/Config.in b/linux/Config.in
index 910d9a524..9ebe0c963 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -261,11 +261,12 @@ config BR2_LINUX_KERNEL_USE_CUSTOM_DTS
endchoice
config BR2_LINUX_KERNEL_INTREE_DTS_NAME
- string "Device Tree Source file name"
+ string "Device Tree Source file names"
depends on BR2_LINUX_KERNEL_USE_INTREE_DTS
help
Name of the device tree source file, without
- the trailing .dts
+ the trailing .dts. You can provide a list of
+ dts files to build, separated by spaces.
config BR2_LINUX_KERNEL_CUSTOM_DTS_PATH
string "Device Tree Source file path"
diff --git a/linux/linux.mk b/linux/linux.mk
index c4bdf9090..3321d809a 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -187,10 +187,13 @@ endef
ifeq ($(BR2_LINUX_KERNEL_DTS_SUPPORT),y)
ifeq ($(BR2_LINUX_KERNEL_DTB_IS_SELF_BUILT),)
define LINUX_BUILD_DTB
- $(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(KERNEL_DTS_NAME).dtb
+ $(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) \
+ $(addsuffix .dtb, $(call qstrip, $(KERNEL_DTS_NAME)))
endef
define LINUX_INSTALL_DTB
- cp $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb $(BINARIES_DIR)/
+ cp $(addprefix $(KERNEL_ARCH_PATH)/boot/, \
+ $(addsuffix .dtb, $(call qstrip, $(KERNEL_DTS_NAME)))) \
+ $(BINARIES_DIR)/
endef
endif
endif