summaryrefslogtreecommitdiffstats
path: root/docs/manual/adding-packages-gettext.txt
diff options
context:
space:
mode:
Diffstat (limited to 'docs/manual/adding-packages-gettext.txt')
-rw-r--r--docs/manual/adding-packages-gettext.txt20
1 files changed, 12 insertions, 8 deletions
diff --git a/docs/manual/adding-packages-gettext.txt b/docs/manual/adding-packages-gettext.txt
index e9446d2dd..58fd98d4e 100644
--- a/docs/manual/adding-packages-gettext.txt
+++ b/docs/manual/adding-packages-gettext.txt
@@ -27,16 +27,20 @@ Therefore, Buildroot defines two configuration options:
doesn't provide its own gettext implementation and if locale support
is enabled
-Therefore, packages that unconditionally need gettext should:
+Packages that need gettext only when locale support is enabled should:
-* Use +select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT+
+* use +select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE+ in the
+ +Config.in+ file;
-* Use +$(if $(BR2_NEEDS_GETTEXT),gettext)+ in the package
- +DEPENDENCIES+ variable
+* use +$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)+ in the package
+ +DEPENDENCIES+ variable in the +.mk+ file.
-Packages that need gettext only when locale support is enabled should:
+Packages that unconditionally need gettext (which should be very rare)
+should:
+
+* use +select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT+ in the +Config.in+
+ file;
-* Use +select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE+
+* use +$(if $(BR2_NEEDS_GETTEXT),gettext)+ in the package
+ +DEPENDENCIES+ variable in the +.mk+ file.
-* Use +$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)+ in the package
- +DEPENDENCIES+ variable