summaryrefslogtreecommitdiffstats
path: root/boot/barebox/barebox.mk
diff options
context:
space:
mode:
Diffstat (limited to 'boot/barebox/barebox.mk')
-rw-r--r--boot/barebox/barebox.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index a025d5f4a..6cc497669 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -72,7 +72,11 @@ define BAREBOX_BUILD_CMDS
endef
define BAREBOX_INSTALL_IMAGES_CMDS
- cp $(@D)/barebox.bin $(BINARIES_DIR)
+ if test -h $(@D)/barebox-flash-image ; then \
+ cp -L $(@D)/barebox-flash-image $(BINARIES_DIR)/barebox.bin ; \
+ else \
+ cp $(@D)/barebox.bin $(BINARIES_DIR);\
+ fi
endef
ifeq ($(BR2_TARGET_BAREBOX_BAREBOXENV),y)