summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/vim/Config.in2
-rw-r--r--package/vim/vim.mk12
2 files changed, 7 insertions, 7 deletions
diff --git a/package/vim/Config.in b/package/vim/Config.in
index 30b73d305..0da158fad 100644
--- a/package/vim/Config.in
+++ b/package/vim/Config.in
@@ -12,4 +12,4 @@ config BR2_PACKAGE_VIM_RUNTIME
depends on BR2_PACKAGE_VIM
help
Install VIM runtime (syntax highlighing + macros).
- This option adds about 13MB of data to /usr/share/
+ This option adds about 15MB of data to /usr/share/
diff --git a/package/vim/vim.mk b/package/vim/vim.mk
index f5988d19f..ef8d9259b 100644
--- a/package/vim/vim.mk
+++ b/package/vim/vim.mk
@@ -4,10 +4,10 @@
#
#############################################################
-# svn r1889 == 7.2 release + patchlevel 446
-VIM_SITE = https://vim.svn.sourceforge.net/svnroot/vim/branches/vim7.2
-VIM_SITE_METHOD = svn
-VIM_VERSION = 1889
+# hg 21219ffc9790 = 7.3 release + patchlevel 487
+VIM_SITE = https://vim.googlecode.com/hg
+VIM_SITE_METHOD = hg
+VIM_VERSION = 21219ffc9790
VIM_DEPENDENCIES = ncurses
VIM_SUBDIR = src
VIM_CONF_ENV = vim_cv_toupper_broken=no \
@@ -19,8 +19,8 @@ VIM_CONF_ENV = vim_cv_toupper_broken=no \
vim_cv_memmove_handles_overlap=yes \
ac_cv_sizeof_int=4 \
ac_cv_small_wchar_t=no
-
-VIM_CONF_OPT = --with-tlib=ncurses
+# GUI/X11 headers leak from the host so forcibly disable them
+VIM_CONF_OPT = --with-tlib=ncurses --enable-gui=no --without-x
define VIM_INSTALL_TARGET_CMDS
cd $(@D)/src; \