summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--project/Makefile.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/project/Makefile.in b/project/Makefile.in
index 034b1fa6c..6aa1d43e9 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -30,7 +30,8 @@ TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
BASE_DIR:=$(shell pwd)
ifdef O
ifeq ("$(origin O)", "command line")
-BASE_DIR := $(O)
+BASE_DIR := $(shell mkdir -p $(O) && cd $(O) && pwd)
+$(if $(BASE_DIR),, $(error output directory "$(O)" does not exist))
endif
endif