summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/rpm/rpm.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/rpm/rpm.mk b/package/rpm/rpm.mk
index c7db76aed..32dd3b1c8 100644
--- a/package/rpm/rpm.mk
+++ b/package/rpm/rpm.mk
@@ -3,7 +3,7 @@
# rpm
#
#############################################################
-RPM_VERSION = 5.0.3
+RPM_VERSION = 5.1.0
RPM_SITE = http://rpm5.org/files/rpm/rpm-5.0/
RPM_AUTORECONF = YES
@@ -18,7 +18,7 @@ RPM_CONF_OPT = --disable-build-versionscript --disable-rpath \
--with-zlib=$(STAGING_DIR) \
--with-libbeecrypt=$(STAGING_DIR) \
--with-popt=$(STAGING_DIR) \
- --disable-mutexsupport \
+ --with-mutex=UNIX/fcntl \
$(DISABLE_NLS)
RPM_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) program_transform_name= install