summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/openssl/openssl.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 62c2f33bd..eb3e803f1 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -60,12 +60,12 @@ $(OPENSSL_HOOK_POST_INSTALL):
ifeq ($(BR2_PACKAGE_OPENSSL_BIN),y)
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/bin/openssl
else
- # libraries gets installed read only, so strip fails
- for i in $(addprefix $(TARGET_DIR)/usr/lib/,libcrypto.so.* libssl.so.*); \
- do chmod +w $$i; $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $$i; done
rm -f $(TARGET_DIR)/usr/bin/openssl
endif
rm -f $(TARGET_DIR)/usr/bin/c_rehash
+ # libraries gets installed read only, so strip fails
+ for i in $(addprefix $(TARGET_DIR)/usr/lib/,libcrypto.so.* libssl.so.*); \
+ do chmod +w $$i; $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $$i; done
ifneq ($(BR2_PACKAGE_OPENSSL_ENGINES),y)
rm -rf $(TARGET_DIR)/usr/lib/engines
else