summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/efl/libecore/libecore.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/efl/libecore/libecore.mk b/package/efl/libecore/libecore.mk
index db14356ae..c76b3ffa2 100644
--- a/package/efl/libecore/libecore.mk
+++ b/package/efl/libecore/libecore.mk
@@ -12,7 +12,13 @@ LIBECORE_INSTALL_STAGING = YES
LIBECORE_DEPENDENCIES = host-pkg-config libeina
HOST_LIBECORE_DEPENDENCIES = host-pkg-config host-libeina host-libevas
-HOST_LIBECORE_CONF_OPT += --enable-ecore-evas
+HOST_LIBECORE_CONF_OPT += \
+ --enable-ecore-evas \
+ --disable-simple-x11 \
+ --disable-ecore-directfb \
+ --disable-ecore-x \
+ --disable-ecore-x-xcb \
+ --disable-ecore-imf-xim
# default options
LIBECORE_CONF_OPT = --disable-simple-x11