summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in2
-rw-r--r--package/lsof/lsof.mk3
2 files changed, 5 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index a3101467f..34570beb1 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -24,7 +24,9 @@ source "package/dmalloc/Config.in"
source "package/kexec/Config.in"
source "package/latencytop/Config.in"
source "package/lmbench/Config.in"
+if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
source "package/lsof/Config.in"
+endif
source "package/ltp-testsuite/Config.in"
source "package/lttng-babeltrace/Config.in"
source "package/lttng-modules/Config.in"
diff --git a/package/lsof/lsof.mk b/package/lsof/lsof.mk
index c07fb2da3..7bc22c01d 100644
--- a/package/lsof/lsof.mk
+++ b/package/lsof/lsof.mk
@@ -8,6 +8,9 @@ LSOF_VERSION = 4.85
LSOF_SOURCE = lsof_$(LSOF_VERSION).tar.bz2
LSOF_SITE = ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/
+# Make certain full-blown lsof gets built after the busybox version (1.20+)
+LSOF_DEPENDENCIES += $(if $(BR2_PACKAGE_BUSYBOX),busybox)
+
BR2_LSOF_CFLAGS =
ifeq ($(BR2_LARGEFILE),)
BR2_LSOF_CFLAGS += -U_FILE_OFFSET_BITS