summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in24
-rw-r--r--Makefile6
2 files changed, 10 insertions, 20 deletions
diff --git a/Config.in b/Config.in
index da3619a2a..0f8ddf4fa 100644
--- a/Config.in
+++ b/Config.in
@@ -21,25 +21,17 @@ config BR2_WGET
string "Wget command"
default "wget --passive-ftp -nd"
-config BR2_SVN_CO
- string "Subversion (svn) command to download source tree"
- default "svn co"
+config BR2_SVN
+ string "Subversion (svn) command"
+ default "svn"
-config BR2_SVN_UP
- string "Subversion (svn) command to update source tree"
- default "svn up"
-
-config BR2_BZR_CO
- string "Bazaar (bzr) command to download source tree"
- default "bzr co"
-
-config BR2_BZR_UP
- string "Bazaar (bzr) command to update source tree"
- default "bzr up"
+config BR2_BZR
+ string "Bazaar (bzr) command"
+ default "bzr"
config BR2_GIT
- string "Git command to download source tree"
- default "git clone"
+ string "Git command"
+ default "git"
config BR2_ZCAT
string "zcat command"
diff --git a/Makefile b/Makefile
index 59a0e2303..778040308 100644
--- a/Makefile
+++ b/Makefile
@@ -245,10 +245,8 @@ ARCH:=$(ARCH)_$(call qstrip,$(BR2_xtensa_core_name))
endif
WGET:=$(call qstrip,$(BR2_WGET)) $(QUIET)
-SVN_CO:=$(call qstrip,$(BR2_SVN_CO)) $(QUIET)
-SVN_UP:=$(call qstrip,$(BR2_SVN_UP)) $(QUIET)
-BZR_CO:=$(call qstrip,$(BR2_BZR_CO)) $(QUIET)
-BZR_UP:=$(call qstrip,$(BR2_BZR_UP)) $(QUIET)
+SVN:=$(call qstrip,$(BR2_SVN)) $(QUIET)
+BZR:=$(call qstrip,$(BR2_BZR)) $(QUIET)
GIT:=$(call qstrip,$(BR2_GIT)) $(QUIET)
ZCAT:=$(call qstrip,$(BR2_ZCAT))
BZCAT:=$(call qstrip,$(BR2_BZCAT))