summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/fbterm/Config.in13
-rw-r--r--package/fbterm/fbterm.mk12
3 files changed, 26 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 8cb3b22cb..5d6250cbe 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -112,6 +112,7 @@ source "package/fbgrab/Config.in"
if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
source "package/fbset/Config.in"
endif
+source "package/fbterm/Config.in"
source "package/fbv/Config.in"
source "package/imagemagick/Config.in"
source "package/linux-fusion/Config.in"
diff --git a/package/fbterm/Config.in b/package/fbterm/Config.in
new file mode 100644
index 000000000..1e4ab4c0d
--- /dev/null
+++ b/package/fbterm/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_FBTERM
+ bool "fbterm"
+ depends on (BR2_INSTALL_LIBSTDCPP && BR2_ENABLE_LOCALE && BR2_USE_WCHAR)
+ select BR2_PACKAGE_FONTCONFIG
+ select BR2_PACKAGE_LIBERATION
+ help
+ fbterm is a fast terminal emulator for Linux with frame buffer
+ device or VESA video card.
+
+ http://code.google.com/p/fbterm/
+
+comment "fbterm requires a toolchain with C++, WCHAR and locale support"
+ depends on !(BR2_INSTALL_LIBSTDCPP && BR2_ENABLE_LOCALE && BR2_USE_WCHAR)
diff --git a/package/fbterm/fbterm.mk b/package/fbterm/fbterm.mk
new file mode 100644
index 000000000..ddb5b2b31
--- /dev/null
+++ b/package/fbterm/fbterm.mk
@@ -0,0 +1,12 @@
+############################################
+#
+# fbterm
+#
+############################################
+
+FBTERM_VERSION = 1.7.0
+FBTERM_SITE = http://fbterm.googlecode.com/files/
+
+FBTERM_DEPENDENCIES = fontconfig liberation
+
+$(eval $(call AUTOTARGETS))