summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/php/php.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index 2668774d3..eaf39c36a 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -156,6 +156,9 @@ else
PHP_CONF_OPT += --with-pdo-sqlite
endif
PHP_CONF_ENV += CFLAGS+=" -DSQLITE_OMIT_LOAD_EXTENSION"
+ifneq ($(BR2_LARGEFILE),y)
+ PHP_CONF_ENV += CFLAGS+=" -DSQLITE_DISABLE_LFS"
+endif
endif
ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_MYSQL),y)
PHP_CONF_OPT += --with-pdo-mysql=$(STAGING_DIR)/usr