summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/libvorbis/Config.in8
-rw-r--r--package/libvorbis/libvorbis.mk18
2 files changed, 0 insertions, 26 deletions
diff --git a/package/libvorbis/Config.in b/package/libvorbis/Config.in
index 4d5907448..e9d8fc7e6 100644
--- a/package/libvorbis/Config.in
+++ b/package/libvorbis/Config.in
@@ -15,14 +15,6 @@ config BR2_PACKAGE_LIBVORBIS
performance than MPEG-1/2 audio layer 3, MPEG-4 audio (TwinVQ),
WMA and PAC.
-
-config BR2_PACKAGE_LIBVORBIS_HEADERS
- bool "libvorbis target headers"
- default n
- depends on BR2_PACKAGE_LIBVORBIS
- help
- Add target headers for the Vorbis open source audio decoder
-
config BR2_PACKAGE_LIBVORBIS_TREMOR
bool "libvorbis integer implementation"
default y if BR2_arm || BR2_avr32
diff --git a/package/libvorbis/libvorbis.mk b/package/libvorbis/libvorbis.mk
index b6358778a..3e496d938 100644
--- a/package/libvorbis/libvorbis.mk
+++ b/package/libvorbis/libvorbis.mk
@@ -47,15 +47,6 @@ $(TARGET_DIR)/usr/lib/libvorbis.so: $(LIBVORBIS_DIR)/.libs
$(MAKE) prefix=$(TARGET_DIR)/usr -C $(LIBVORBIS_DIR) install
touch $@
-$(TARGET_DIR)/usr/lib/libvorbis.a: $(TARGET_DIR)/usr/lib/libvorbis.so
- cp -dpf $(LIBVORBIS_DIR)/lib/libvorbis.a $(TARGET_DIR)/usr/lib/
- touch $@
-
-libvorbis-header: $(TARGET_DIR)/usr/lib/libvorbis.a
- mkdir -p $(TARGET_DIR)/usr/include/vorbis
- cp -dpf $(LIBVORBIS_DIR)/include/vorbis/*.h \
- $(TARGET_DIR)/usr/include/vorbis
-
libvorbis: uclibc pkgconfig libogg $(TARGET_DIR)/usr/lib/libvorbis.so
libvorbis-source: $(DL_DIR)/$(LIBVORBIS_SOURCE)
@@ -124,11 +115,6 @@ $(TARGET_DIR)/usr/lib/tremor.a: $(TARGET_DIR)/usr/lib/tremor.so
cp -dpf $(TREMOR_DIR)/lib/tremor.a $(TARGET_DIR)/usr/lib/
touch $@
-tremor-header: $(TARGET_DIR)/usr/lib/tremor.a
- mkdir -p $(TARGET_DIR)/usr/include/vorbis
- cp -dpf $(TREMOR_DIR)/include/vorbis/*.h \
- $(TARGET_DIR)/usr/include/vorbis
-
tremor: uclibc pkgconfig libogg $(TARGET_DIR)/usr/lib/tremor.so
tremor-source: $(DL_DIR)/$(TREMOR_SOURCE)
@@ -152,7 +138,3 @@ TARGETS+=tremor
endif
TARGETS+=libvorbis
endif
-
-ifeq ($(strip $(BR2_PACKAGE_LIBVORBIS_HEADERS)),y)
-TARGETS+=libvorbis-header
-endif