summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rwxr-xr-xtoolchain/dependencies/dependencies.sh8
2 files changed, 8 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c1df6a303..44676f1f1 100644
--- a/Makefile
+++ b/Makefile
@@ -37,7 +37,7 @@ noconfig_targets := menuconfig config oldconfig randconfig \
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
-include $(TOPDIR).config
endif
-ifneq ($(BUILDROOT_DL_DIR),)
+ifneq ($(BUILDROOT_DL_DIR),)
BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
endif
diff --git a/toolchain/dependencies/dependencies.sh b/toolchain/dependencies/dependencies.sh
index d1bccd247..60b9b6596 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/toolchain/dependencies/dependencies.sh
@@ -11,6 +11,13 @@ export LC_ALL=C
# check build system 'environment'
#
#############################################################
+if test -n "$BUILDROOT_DL_DIR" ; then
+ /bin/echo -e "Overriding \$(DL_DIR) in '.config'. Ok"
+ /bin/echo -e "External download directory: Ok ($BUILDROOT_DL_DIR)"
+else
+ echo "BUILDROOT_DL_DIR clean: Ok"
+fi
+
if test -n "$CC" ; then
echo "CC clean: FALSE"
/bin/echo -e "\n\nYou must run 'unset CC' so buildroot can run with";
@@ -19,7 +26,6 @@ if test -n "$CC" ; then
fi;
echo "CC clean: Ok"
-
if test -n "$CXX" ; then
echo "CXX clean: FALSE"
/bin/echo -e "\n\nYou must run 'unset CXX' so buildroot can run with";