summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/jamvm/jamvm.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/jamvm/jamvm.mk b/package/jamvm/jamvm.mk
index f0765d7cd..3f0536136 100644
--- a/package/jamvm/jamvm.mk
+++ b/package/jamvm/jamvm.mk
@@ -8,4 +8,10 @@ JAMVM_CONF_OPT = \
--disable-shared \
--without-pic
+# jamvm has ARM assembly code that cannot be compiled in Thumb2 mode,
+# so we must force traditional ARM mode.
+ifeq ($(BR2_arm),y)
+JAMVM_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -marm"
+endif
+
$(eval $(autotools-package))