summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/parted/Config.in14
-rw-r--r--package/parted/parted.mk13
3 files changed, 28 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 4838edc80..36a221cfb 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -202,6 +202,7 @@ source "package/mtd/Config.in"
source "package/ntfs-3g/Config.in"
source "package/open2300/Config.in"
source "package/openocd/Config.in"
+source "package/parted/Config.in"
source "package/pciutils/Config.in"
source "package/picocom/Config.in"
source "package/rng-tools/Config.in"
diff --git a/package/parted/Config.in b/package/parted/Config.in
new file mode 100644
index 000000000..610c04022
--- /dev/null
+++ b/package/parted/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_PARTED
+ bool "parted"
+ depends on BR2_LARGEFILE
+ depends on BR2_USE_WCHAR
+ select BR2_PACKAGE_LVM2
+ select BR2_PACKAGE_READLINE
+ select BR2_PACKAGE_UTIL_LINUX
+ help
+ parted, the GNU partition resizing program
+
+ http://www.gnu.org/software/parted/
+
+comment "parted requires a toolchain with LARGEFILE+WCHAR support"
+ depends on !(BR2_LARGEFILE && BR2_USE_WCHAR)
diff --git a/package/parted/parted.mk b/package/parted/parted.mk
new file mode 100644
index 000000000..c4107e7b4
--- /dev/null
+++ b/package/parted/parted.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# parted
+#
+#############################################################
+
+PARTED_VERSION = 3.1
+PARTED_SOURCE = parted-$(PARTED_VERSION).tar.xz
+PARTED_SITE = $(BR2_GNU_MIRROR)/parted
+PARTED_DEPENDENCIES = readline util-linux lvm2
+PARTED_INSTALL_STAGING = YES
+
+$(eval $(call AUTOTARGETS))