summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/database/mysql_client/Config.in2
-rw-r--r--package/database/sqlite/Config.in2
-rw-r--r--package/ipsec-tools/Config.in2
-rw-r--r--package/lua/Config.in2
-rw-r--r--package/php/Config.ext2
-rw-r--r--package/readline/Config.in2
-rw-r--r--package/readline/readline.mk2
-rw-r--r--scripts/test/Config.in.test.buildall2
-rw-r--r--target/device/ARMLTD/integrator926/integrator926_defconfig2
-rw-r--r--target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig2
-rw-r--r--target/device/Atmel/at91rm9200df/at91rm9200df_defconfig2
-rw-r--r--target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig2
-rw-r--r--target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig2
-rw-r--r--target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig2
-rw-r--r--target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig2
-rw-r--r--target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig2
-rw-r--r--target/device/Atmel/atngw100-base/atngw100-base_defconfig2
-rw-r--r--target/device/Atmel/atngw100-expanded/atngw100-expanded_defconfig2
-rw-r--r--target/device/Atmel/atngw100/atngw100_defconfig2
-rw-r--r--target/device/Atmel/atstk1005/atstk1005_defconfig2
-rw-r--r--target/device/Atmel/atstk100x/atstk100x_defconfig2
-rw-r--r--target/device/KwikByte/kb9202/kb9202_defconfig2
-rw-r--r--target/device/valka/v100sc2_defconfig2
-rw-r--r--target/device/x86/i686/i386_defconfig2
-rw-r--r--target/device/x86/i686/i686_defconfig2
25 files changed, 25 insertions, 25 deletions
diff --git a/package/database/mysql_client/Config.in b/package/database/mysql_client/Config.in
index 01cf71725..92b349af9 100644
--- a/package/database/mysql_client/Config.in
+++ b/package/database/mysql_client/Config.in
@@ -2,7 +2,7 @@ config BR2_PACKAGE_MYSQL_CLIENT
bool "MySQL 5.1 client"
depends on BR2_INSTALL_LIBSTDCPP
select BR2_PACKAGE_NCURSES
- select BR2_READLINE
+ select BR2_PACKAGE_READLINE
help
MySQL client
diff --git a/package/database/sqlite/Config.in b/package/database/sqlite/Config.in
index 344af8def..c445c1e30 100644
--- a/package/database/sqlite/Config.in
+++ b/package/database/sqlite/Config.in
@@ -1,7 +1,7 @@
config BR2_PACKAGE_SQLITE
bool "sqlite"
select BR2_PACKAGE_NCURSES
- select BR2_READLINE
+ select BR2_PACKAGE_READLINE
help
SQLite is a small C library that implements a self-contained,
embeddable, zero-configuration SQL database engine.
diff --git a/package/ipsec-tools/Config.in b/package/ipsec-tools/Config.in
index f4e227f55..50777ab39 100644
--- a/package/ipsec-tools/Config.in
+++ b/package/ipsec-tools/Config.in
@@ -51,7 +51,7 @@ config BR2_PACKAGE_IPSEC_TOOLS_IPV6
config BR2_PACKAGE_IPSEC_TOOLS_READLINE
depends on BR2_PACKAGE_IPSEC_TOOLS
- select BR2_READLINE
+ select BR2_PACKAGE_READLINE
bool "Enable readline input support if available."
config BR2_PACKAGE_IPSEC_TOOLS_LIBS
diff --git a/package/lua/Config.in b/package/lua/Config.in
index 89de1a821..95108cdc3 100644
--- a/package/lua/Config.in
+++ b/package/lua/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_LUA
bool "lua"
- select BR2_READLINE
+ select BR2_PACKAGE_READLINE
select BR2_PACKAGE_NCURSES
help
Lua is a powerful, fast, light-weight, embeddable scripting language.
diff --git a/package/php/Config.ext b/package/php/Config.ext
index f25c93729..7f583fcf8 100644
--- a/package/php/Config.ext
+++ b/package/php/Config.ext
@@ -86,7 +86,7 @@ config BR2_PACKAGE_PHP_EXT_JSON
config BR2_PACKAGE_PHP_EXT_READLINE
bool "readline"
- depends on BR2_PACKAGE_PHP && (BR2_PACKAGE_PHP_CLI || BR2_PACKAGE_PHP_CGI) && BR2_READLINE
+ depends on BR2_PACKAGE_PHP && (BR2_PACKAGE_PHP_CLI || BR2_PACKAGE_PHP_CGI) && BR2_PACKAGE_READLINE
help
readline support
diff --git a/package/readline/Config.in b/package/readline/Config.in
index 9ab61abc1..4319b8b54 100644
--- a/package/readline/Config.in
+++ b/package/readline/Config.in
@@ -1,5 +1,5 @@
#
-config BR2_READLINE
+config BR2_PACKAGE_READLINE
bool "readline"
help
Enable GNU readline support?
diff --git a/package/readline/readline.mk b/package/readline/readline.mk
index 44b1a01b0..716d86fd0 100644
--- a/package/readline/readline.mk
+++ b/package/readline/readline.mk
@@ -86,6 +86,6 @@ readline-clean:
readline-dirclean:
rm -rf $(READLINE_DIR)
-ifeq ($(BR2_READLINE),y)
+ifeq ($(BR2_PACKAGE_READLINE),y)
TARGETS+=readline
endif
diff --git a/scripts/test/Config.in.test.buildall b/scripts/test/Config.in.test.buildall
index 6a5e21124..163387dd9 100644
--- a/scripts/test/Config.in.test.buildall
+++ b/scripts/test/Config.in.test.buildall
@@ -45,7 +45,7 @@ config BR2_TARGET_TEST_PACKAGES
select BR2_PACKAGE_MPATROL
select BR2_PACKAGE_OPROFILE
select BR2_PACKAGE_PKGCONFIG
- select BR2_READLINE
+ select BR2_PACKAGE_READLINE
select BR2_PACKAGE_READLINE_TARGET
select BR2_PACKAGE_READLINE_HEADERS
diff --git a/target/device/ARMLTD/integrator926/integrator926_defconfig b/target/device/ARMLTD/integrator926/integrator926_defconfig
index 066947379..872aab100 100644
--- a/target/device/ARMLTD/integrator926/integrator926_defconfig
+++ b/target/device/ARMLTD/integrator926/integrator926_defconfig
@@ -306,7 +306,7 @@ BR2_HOST_FAKEROOT=y
# oprofile requires a toolchain with C++ support enabled
#
# BR2_PACKAGE_PKGCONFIG is not set
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
# BR2_PACKAGE_PCRE is not set
#
diff --git a/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig b/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig
index 847f17796..652eaf3c4 100644
--- a/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig
+++ b/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig
@@ -311,7 +311,7 @@ BR2_PACKAGE_M4=y
# BR2_PACKAGE_MPATROL is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
BR2_PACKAGE_READLINE_TARGET=y
# BR2_PACKAGE_READLINE_HEADERS is not set
# BR2_PACKAGE_PCRE is not set
diff --git a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
index 3b1d963b1..188f73483 100644
--- a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
+++ b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
@@ -373,7 +373,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
BR2_PACKAGE_READLINE_TARGET=y
# BR2_PACKAGE_READLINE_HEADERS is not set
# BR2_PACKAGE_PCRE is not set
diff --git a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
index f99042444..5de120470 100644
--- a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
+++ b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
@@ -387,7 +387,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
BR2_PACKAGE_READLINE_TARGET=y
# BR2_PACKAGE_READLINE_HEADERS is not set
# BR2_PACKAGE_PCRE is not set
diff --git a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig b/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
index 365a2aa68..7b3a250d2 100644
--- a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
+++ b/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
@@ -284,7 +284,7 @@ BR2_PACKAGE_LIBINTL=y
BR2_PACKAGE_LIBTOOL=y
BR2_PACKAGE_M4=y
BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
BR2_PACKAGE_READLINE_TARGET=y
# BR2_PACKAGE_XERCES is not set
diff --git a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
index b1dd96ffd..10bda4745 100644
--- a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
+++ b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
@@ -381,7 +381,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
BR2_PACKAGE_READLINE_TARGET=y
# BR2_PACKAGE_READLINE_HEADERS is not set
# BR2_PACKAGE_PCRE is not set
diff --git a/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig b/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig
index fb7018956..006fc6d4e 100644
--- a/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig
+++ b/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig
@@ -378,7 +378,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
BR2_PACKAGE_READLINE_TARGET=y
# BR2_PACKAGE_READLINE_HEADERS is not set
# BR2_PACKAGE_PCRE is not set
diff --git a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig b/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig
index 11d5344e1..9034bd73d 100644
--- a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig
+++ b/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig
@@ -378,7 +378,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
BR2_PACKAGE_READLINE_TARGET=y
# BR2_PACKAGE_READLINE_HEADERS is not set
# BR2_PACKAGE_PCRE is not set
diff --git a/target/device/Atmel/atngw100-base/atngw100-base_defconfig b/target/device/Atmel/atngw100-base/atngw100-base_defconfig
index aacac6f88..cb231ca7b 100644
--- a/target/device/Atmel/atngw100-base/atngw100-base_defconfig
+++ b/target/device/Atmel/atngw100-base/atngw100-base_defconfig
@@ -326,7 +326,7 @@ BR2_HOST_FAKEROOT=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
# BR2_PACKAGE_PCRE is not set
#
diff --git a/target/device/Atmel/atngw100-expanded/atngw100-expanded_defconfig b/target/device/Atmel/atngw100-expanded/atngw100-expanded_defconfig
index 4852ba936..0f30ad42a 100644
--- a/target/device/Atmel/atngw100-expanded/atngw100-expanded_defconfig
+++ b/target/device/Atmel/atngw100-expanded/atngw100-expanded_defconfig
@@ -336,7 +336,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
# BR2_PACKAGE_READLINE_TARGET is not set
# BR2_PACKAGE_PCRE is not set
diff --git a/target/device/Atmel/atngw100/atngw100_defconfig b/target/device/Atmel/atngw100/atngw100_defconfig
index c4a2fc817..6c4ada2d3 100644
--- a/target/device/Atmel/atngw100/atngw100_defconfig
+++ b/target/device/Atmel/atngw100/atngw100_defconfig
@@ -326,7 +326,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
# BR2_PACKAGE_PCRE is not set
#
diff --git a/target/device/Atmel/atstk1005/atstk1005_defconfig b/target/device/Atmel/atstk1005/atstk1005_defconfig
index f788fa048..761caa43c 100644
--- a/target/device/Atmel/atstk1005/atstk1005_defconfig
+++ b/target/device/Atmel/atstk1005/atstk1005_defconfig
@@ -326,7 +326,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
# BR2_PACKAGE_PCRE is not set
#
diff --git a/target/device/Atmel/atstk100x/atstk100x_defconfig b/target/device/Atmel/atstk100x/atstk100x_defconfig
index db4155ddb..5942fd2e3 100644
--- a/target/device/Atmel/atstk100x/atstk100x_defconfig
+++ b/target/device/Atmel/atstk100x/atstk100x_defconfig
@@ -336,7 +336,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
# BR2_PACKAGE_PCRE is not set
#
diff --git a/target/device/KwikByte/kb9202/kb9202_defconfig b/target/device/KwikByte/kb9202/kb9202_defconfig
index 6ec31d30c..d90f41542 100644
--- a/target/device/KwikByte/kb9202/kb9202_defconfig
+++ b/target/device/KwikByte/kb9202/kb9202_defconfig
@@ -302,7 +302,7 @@ BR2_HOST_FAKEROOT=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
# BR2_PACKAGE_PKGCONFIG is not set
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
# BR2_PACKAGE_PCRE is not set
#
diff --git a/target/device/valka/v100sc2_defconfig b/target/device/valka/v100sc2_defconfig
index f5134ae04..c087609db 100644
--- a/target/device/valka/v100sc2_defconfig
+++ b/target/device/valka/v100sc2_defconfig
@@ -299,7 +299,7 @@ BR2_PACKAGE_LIBINTL=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
BR2_PACKAGE_PCRE=y
# BR2_PACKAGE_TMC is not set
diff --git a/target/device/x86/i686/i386_defconfig b/target/device/x86/i686/i386_defconfig
index 4bee5c6a5..319094cfb 100644
--- a/target/device/x86/i686/i386_defconfig
+++ b/target/device/x86/i686/i386_defconfig
@@ -312,7 +312,7 @@ BR2_HOST_FAKEROOT=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
# BR2_PACKAGE_PKGCONFIG is not set
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
# BR2_PACKAGE_VALGRIND is not set
# BR2_PACKAGE_PCRE is not set
diff --git a/target/device/x86/i686/i686_defconfig b/target/device/x86/i686/i686_defconfig
index bce241125..ad914cbe6 100644
--- a/target/device/x86/i686/i686_defconfig
+++ b/target/device/x86/i686/i686_defconfig
@@ -312,7 +312,7 @@ BR2_HOST_FAKEROOT=y
# BR2_PACKAGE_M4 is not set
# BR2_PACKAGE_OPROFILE is not set
# BR2_PACKAGE_PKGCONFIG is not set
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
# BR2_PACKAGE_VALGRIND is not set
# BR2_PACKAGE_PCRE is not set