summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in10
-rw-r--r--Makefile4
2 files changed, 12 insertions, 2 deletions
diff --git a/Config.in b/Config.in
index 423499ae4..af26bbebb 100644
--- a/Config.in
+++ b/Config.in
@@ -72,6 +72,16 @@ config BR2_DL_DIR
The default is $(TOPDIR)/dl
+config BR2_HOST_DIR
+ string "Host dir"
+ default "$(BASE_DIR)/host"
+ help
+ Directory to store all the binary files that are built for the host.
+ This includes the cross compilation toolchain when building the
+ internal buildroot toolchain.
+
+ The default is $(BASE_DIR)/host
+
menu "Mirrors and Download locations"
config BR2_PRIMARY_SITE
diff --git a/Makefile b/Makefile
index 956374082..914d2ed36 100644
--- a/Makefile
+++ b/Makefile
@@ -274,8 +274,8 @@ TAR_OPTIONS=$(call qstrip,$(BR2_TAR_OPTIONS)) -xf
GNU_TARGET_SUFFIX:=-$(call qstrip,$(BR2_GNU_TARGET_SUFFIX))
-# packages compiled for the host goes here
-HOST_DIR:=$(BASE_DIR)/host
+# packages compiled for the host go here
+HOST_DIR:=$(call qstrip,$(BR2_HOST_DIR))
# stamp (dependency) files go here
STAMP_DIR:=$(BASE_DIR)/stamps