summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/gettext/Config.in14
-rw-r--r--package/gettext/gettext.mk7
2 files changed, 7 insertions, 14 deletions
diff --git a/package/gettext/Config.in b/package/gettext/Config.in
index 0ee4065c4..04f7de673 100644
--- a/package/gettext/Config.in
+++ b/package/gettext/Config.in
@@ -7,17 +7,15 @@ config BR2_PACKAGE_GETTEXT
framework to help other GNU packages produce multi-lingual
messages.
+ Only the gettext libraries will be installed in the
+ target. The full gettext suite, including tools, will be
+ installed in the staging directory.
+
http://www.gnu.org/software/gettext/
comment "gettext requires a toolchain with WCHAR support"
depends on BR2_NEEDS_GETTEXT && !BR2_USE_WCHAR
config BR2_PACKAGE_LIBINTL
- bool "libintl"
- depends on BR2_NEEDS_GETTEXT
- depends on BR2_USE_WCHAR
- help
- Selecting this package installs all of gettext in the staging
- directory and the shared library for it's use in the target.
-
- http://www.gnu.org/software/gettext/
+ bool
+ select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
diff --git a/package/gettext/gettext.mk b/package/gettext/gettext.mk
index 6b2c336d0..4dff94162 100644
--- a/package/gettext/gettext.mk
+++ b/package/gettext/gettext.mk
@@ -112,7 +112,7 @@ $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY): $(GETTEXT_DIR)/$(GETTEXT_BINARY)
gettext-legal-info:
@$(call legal-warning-pkg,gettext,legal-info not yet implemented)
-gettext: host-pkg-config $(if $(BR2_PACKAGE_LIBICONV),libiconv) $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY)
+gettext: host-pkg-config $(if $(BR2_PACKAGE_LIBICONV),libiconv) $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY) $(TARGET_DIR)/$(LIBINTL_TARGET_BINARY)
gettext-unpacked: $(GETTEXT_DIR)/.unpacked
@@ -139,16 +139,11 @@ $(TARGET_DIR)/usr/lib/libintl.so: $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY)
libgettext*.so*.la libintl*.so*.la)
touch -c $@
-libintl: $(TARGET_DIR)/$(LIBINTL_TARGET_BINARY)
-
#############################################################
#
# Toplevel Makefile options
#
#############################################################
-ifeq ($(BR2_PACKAGE_LIBINTL),y)
-TARGETS+=libintl
-endif
ifeq ($(BR2_PACKAGE_GETTEXT),y)
TARGETS+=gettext
endif