summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/ccid/Config.in1
-rw-r--r--package/pcsc-lite/Config.in1
-rw-r--r--package/pcsc-lite/pcsc-lite.mk5
3 files changed, 6 insertions, 1 deletions
diff --git a/package/ccid/Config.in b/package/ccid/Config.in
index c9b77d13c..c85a71c3e 100644
--- a/package/ccid/Config.in
+++ b/package/ccid/Config.in
@@ -3,6 +3,7 @@ config BR2_PACKAGE_CCID
select BR2_PACKAGE_PCSC_LITE
select BR2_PACKAGE_LIBUSB
depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
+ depends on BR2_USE_MMU # pcsc-lite
help
PC/SC driver for USB CCID smart card readers
diff --git a/package/pcsc-lite/Config.in b/package/pcsc-lite/Config.in
index 621cc668f..d6629d0f3 100644
--- a/package/pcsc-lite/Config.in
+++ b/package/pcsc-lite/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_PCSC_LITE
bool "pcsc-lite"
depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_USE_MMU # fork()
help
Middleware to access smart card using SCard API (PC/SC).
diff --git a/package/pcsc-lite/pcsc-lite.mk b/package/pcsc-lite/pcsc-lite.mk
index d1d7691da..e1def7c03 100644
--- a/package/pcsc-lite/pcsc-lite.mk
+++ b/package/pcsc-lite/pcsc-lite.mk
@@ -2,12 +2,15 @@
#
# PCSC-Lite
#
-# ########################################################
+#########################################################
+
PCSC_LITE_VERSION = 1.8.6
PCSC_LITE_SOURCE = pcsc-lite-$(PCSC_LITE_VERSION).tar.bz2
PCSC_LITE_SITE = http://alioth.debian.org/frs/download.php/3757
PCSC_LITE_INSTALL_STAGING = YES
PCSC_LITE_DEPENDENCIES = host-pkgconf
+PCSC_LITE_LICENSE = BSD-3c
+PCSC_LITE_LICENSE_FILES = COPYING
# - libudev and libusb are optional
# - libudev and libusb can't be used together