summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/libcofi/Config.in8
-rw-r--r--package/libcofi/libcofi.mk20
3 files changed, 29 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index c25ade239..3681dd355 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -512,6 +512,7 @@ endmenu
menu "Other"
source "package/apr/Config.in"
source "package/apr-util/Config.in"
+source "package/libcofi/Config.in"
source "package/classpath/Config.in"
source "package/fftw/Config.in"
source "package/libargtable2/Config.in"
diff --git a/package/libcofi/Config.in b/package/libcofi/Config.in
new file mode 100644
index 000000000..e9914d6e0
--- /dev/null
+++ b/package/libcofi/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBCOFI
+ bool "libcofi"
+ depends on BR2_arm
+ help
+ A replacement for memcpy and memset functionality for the
+ Raspberry Pi with the intention of gaining greater performance.
+
+ https://github.com/simonjhall/copies-and-fills
diff --git a/package/libcofi/libcofi.mk b/package/libcofi/libcofi.mk
new file mode 100644
index 000000000..e2ce70247
--- /dev/null
+++ b/package/libcofi/libcofi.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# libcofi
+#
+#############################################################
+
+LIBCOFI_VERSION = 7313fbe12b0593034d0a1b606bf33c7cf4ababce
+LIBCOFI_SITE = http://github.com/simonjhall/copies-and-fills/tarball/master
+LIBCOFI_LICENSE = LGPLv2.1
+LIBCOFI_LICENSE_FILES = README.md
+
+define LIBCOFI_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define LIBCOFI_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/libcofi_rpi.so $(TARGET_DIR)/usr/lib/libcofi_rpi.so
+endef
+
+$(eval $(generic-package))