summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/libmhash/Config.in9
-rw-r--r--package/libmhash/libmhash.mk14
3 files changed, 24 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 770d842fc..01e3694f6 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -371,6 +371,7 @@ source "package/beecrypt/Config.in"
source "package/gnutls/Config.in"
source "package/libgcrypt/Config.in"
source "package/libgpg-error/Config.in"
+source "package/libmhash/Config.in"
source "package/libnss/Config.in"
source "package/libsha1/Config.in"
source "package/nettle/Config.in"
diff --git a/package/libmhash/Config.in b/package/libmhash/Config.in
new file mode 100644
index 000000000..a9bd51a2c
--- /dev/null
+++ b/package/libmhash/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBMHASH
+ bool "libmhash"
+ help
+ Mhash is a free (under GNU Lesser GPL) library which provides
+ a uniform interface to a large number of hash algorithms.
+ These algorithms can be used to compute checksums, message digests,
+ and other signatures.
+
+ http://mhash.sourceforge.net/
diff --git a/package/libmhash/libmhash.mk b/package/libmhash/libmhash.mk
new file mode 100644
index 000000000..aa05f93df
--- /dev/null
+++ b/package/libmhash/libmhash.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# libmhash
+#
+#############################################################
+
+LIBMHASH_VERSION = 0.9.9.9
+LIBMHASH_SITE = http://downloads.sourceforge.net/project/mhash/mhash/$(LIBMHASH_VERSION)
+LIBMHASH_SOURCE = mhash-$(LIBMHASH_VERSION).tar.bz2
+LIBMHASH_INSTALL_STAGING = YES
+LIBMHASH_LICENSE = LGPLv2
+LIBMHASH_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))