summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/bmon/bmon.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/bmon/bmon.mk b/package/bmon/bmon.mk
index aa097fbe0..ef2dcf048 100644
--- a/package/bmon/bmon.mk
+++ b/package/bmon/bmon.mk
@@ -14,6 +14,12 @@ else
BMON_CONF_OPT += --disable-curses
endif
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+BMON_DEPENDENCIES += alsa-lib
+else
+BMON_CONF_OPT += --disable-asound
+endif
+
ifneq ($(BR2_PREFER_STATIC_LIB),y)
# link dynamically unless explicitly requested otherwise
BMON_CONF_OPT += --disable-static