summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/pcre/Config.in22
-rw-r--r--package/pcre/pcre.mk4
2 files changed, 26 insertions, 0 deletions
diff --git a/package/pcre/Config.in b/package/pcre/Config.in
index a4e2547ce..5d16e6d1b 100644
--- a/package/pcre/Config.in
+++ b/package/pcre/Config.in
@@ -1,6 +1,28 @@
config BR2_PACKAGE_PCRE
bool "pcre"
+ # Ensure at least the default 8-bit library is enabled.
+ select BR2_PACKAGE_PCRE_8 if \
+ (!BR2_PACKAGE_PCRE_16 && !BR2_PACKAGE_PCRE_32)
help
Perl Compatible Regular Expressions
http://www.pcre.org/
+
+if BR2_PACKAGE_PCRE
+
+config BR2_PACKAGE_PCRE_8
+ bool "8-bit pcre"
+ help
+ This option builds the 8-bits pcre library, i.e 'libpcre'
+
+config BR2_PACKAGE_PCRE_16
+ bool "16-bit pcre"
+ help
+ This option builds the 16-bits pcre library, i.e 'libpcre16'
+
+config BR2_PACKAGE_PCRE_32
+ bool "32-bit pcre"
+ help
+ This option builds the 32-bits pcre library, i.e 'libpcre32'
+
+endif
diff --git a/package/pcre/pcre.mk b/package/pcre/pcre.mk
index 48266ff74..b1339fbbc 100644
--- a/package/pcre/pcre.mk
+++ b/package/pcre/pcre.mk
@@ -16,4 +16,8 @@ ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
PCRE_CONF_OPT = --disable-cpp
endif
+PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_8),--enable-pcre8,--disable-pcre8)
+PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_16),--enable-pcre16,--disable-pcre16)
+PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_32),--enable-pcre32,--disable-pcre32)
+
$(eval $(autotools-package))