summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES2
-rw-r--r--package/nbd/nbd-fix-build-with-disable-lfs.patch30
-rw-r--r--package/nbd/nbd-server-fix-read-eagain.patch21
-rw-r--r--package/nbd/nbd.mk2
4 files changed, 2 insertions, 53 deletions
diff --git a/CHANGES b/CHANGES
index b001d623a..fc1a7fb3c 100644
--- a/CHANGES
+++ b/CHANGES
@@ -15,7 +15,7 @@
Updated/fixed packages: busybox, cdrkit, file, gawk,
gstreamer, intltool, ipsec-tools, iptables, libart, libidn,
- lmbench, lrzsz, ncurses, module-init-tools, netperf,
+ lmbench, lrzsz, ncurses, module-init-tools, nbd, netperf,
ntfsprogs, openssl, php, qt, sqlite, squashfs, tn5250,
usbutils, xkeyboard-config
diff --git a/package/nbd/nbd-fix-build-with-disable-lfs.patch b/package/nbd/nbd-fix-build-with-disable-lfs.patch
deleted file mode 100644
index 5b270aa44..000000000
--- a/package/nbd/nbd-fix-build-with-disable-lfs.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 6d452ab0247770a446cfa6dd9b8b4ddea6c8fa4b Mon Sep 17 00:00:00 2001
-From: Peter Korsgaard <jacmet@sunsite.dk>
-Date: Sun, 22 Nov 2009 23:01:52 +0100
-Subject: [PATCH] lfs.h: fix build with --disable-lfs
-
-Running ./configure with --disable-lfs #define's NBD_LFS to 0 and
-doesn't #undef it, so the LFS check should use #if rather than #ifdef
-similar to how it is done in cliserv.h
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- lfs.h | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/lfs.h b/lfs.h
-index 8f90f81..929ce08 100644
---- a/lfs.h
-+++ b/lfs.h
-@@ -2,7 +2,7 @@
- #define LFS_H
-
- #include "config.h"
--#ifdef NBD_LFS
-+#if NBD_LFS
- #define _FILE_OFFSET_BITS 64
- #define _LARGEFILE_SOURCE
- #endif /* NBD_LFS */
---
-1.6.3.3
-
diff --git a/package/nbd/nbd-server-fix-read-eagain.patch b/package/nbd/nbd-server-fix-read-eagain.patch
deleted file mode 100644
index b1f966c77..000000000
--- a/package/nbd/nbd-server-fix-read-eagain.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- nbd-2.9.11.orig/nbd-server.c
-+++ nbd-2.9.11/nbd-server.c
-@@ -304,10 +304,14 @@
- ssize_t res;
- while (len > 0) {
- DEBUG("*");
-- if ((res = read(f, buf, len)) <= 0)
-- err("Read failed: %m");
-- len -= res;
-- buf += res;
-+ if ((res = read(f, buf, len)) <= 0) {
-+ if(errno != EAGAIN) {
-+ err("Read failed: %m");
-+ }
-+ } else {
-+ len -= res;
-+ buf += res;
-+ }
- }
- }
-
diff --git a/package/nbd/nbd.mk b/package/nbd/nbd.mk
index 8bffaf8cb..fa8dd4f30 100644
--- a/package/nbd/nbd.mk
+++ b/package/nbd/nbd.mk
@@ -4,7 +4,7 @@
#
#############################################################
-NBD_VERSION = 2.9.11
+NBD_VERSION = 2.9.15
NBD_SOURCE = nbd-$(NBD_VERSION).tar.bz2
NBD_SITE=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/nbd/
NBD_CONF_OPT = $(if $(BR2_LARGEFILE),--enable-lfs,--disable-lfs)