summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES8
-rw-r--r--package/sdl_mixer/sdl_mixer.mk22
2 files changed, 26 insertions, 4 deletions
diff --git a/CHANGES b/CHANGES
index c7be667d8..54ddd7478 100644
--- a/CHANGES
+++ b/CHANGES
@@ -26,9 +26,10 @@
libxslt, lighttpd, lite, m4, mdadm, metacity, mtd-utils,
mysql_client, nano, nbd, ncftp, neon, netperf, ntfsprogs, ntp,
openntpd, openssh, openvpn, oprofile, pango, pcre, php,
- prboom, radvd, qt, samba, sdl_sound, shared-mime-info, speex,
- sqlite, squashfs, strace, taglib, tcpdump, tiff, tn5250, udev,
- udpcast, usbmount, usbutils, which, xlib_libX11, zlib
+ prboom, radvd, qt, samba, sdl_mixer, sdl_sound,
+ shared-mime-info, speex, sqlite, squashfs, strace, taglib,
+ tcpdump, tiff, tn5250, udev, udpcast, usbmount, usbutils,
+ which, xlib_libX11, zlib
Deprecated packages: lzma
@@ -37,6 +38,7 @@
Issues resolved (http://bugs.uclibc.org):
+ #2521: Can't compile sdl_mixer, mikmod.h can't be found
#2581: libmms: Update to 0.6, and patch to work on architectures...
2010.08: Released August 31th, 2010:
diff --git a/package/sdl_mixer/sdl_mixer.mk b/package/sdl_mixer/sdl_mixer.mk
index 803349534..c7135ba35 100644
--- a/package/sdl_mixer/sdl_mixer.mk
+++ b/package/sdl_mixer/sdl_mixer.mk
@@ -10,7 +10,27 @@ SDL_MIXER_SITE:=http://www.libsdl.org/projects/SDL_mixer/release/
SDL_MIXER_LIBTOOL_PATCH = NO
SDL_MIXER_INSTALL_STAGING = YES
SDL_MIXER_DEPENDENCIES = sdl
-SDL_MIXER_CONF_OPT = --without-x --with-sdl-prefix=$(STAGING_DIR)/usr
+SDL_MIXER_CONF_OPT = \
+ --without-x \
+ --with-sdl-prefix=$(STAGING_DIR)/usr \
+ --disable-music-midi \
+ --disable-music-mod \
+ --disable-music-mp3 \
+ --disable-music-flac # configure script fails when cross compiling
+
+ifeq ($(BR2_PACKAGE_LIBMAD),y)
+SDL_MIXER_CONF_OPT += --enable-music-mp3-mad-gpl
+SDL_MIXER_DEPENDENCIES += libmad
+else
+SDL_MIXER_CONF_OPT += --disable-music-mp3-mad-gpl
+endif
+
+ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
+SDL_MIXER_CONF_OPT += --enable-music-ogg
+SDL_MIXER_DEPENDENCIES += libvorbis
+else
+SDL_MIXER_CONF_OPT += --disable-music-ogg
+endif
define SDL_MIXER_INSTALL_TARGET_CMDS
cp -dpf $(STAGING_DIR)/usr/lib/libSDL_mixer*.so* $(TARGET_DIR)/usr/lib/