summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile9
-rw-r--r--configs/arm_toolchain_defconfig (renamed from target/device/Atmel/at91sam9260dfc/arm_toolchain_defconfig)0
-rw-r--r--configs/at91rm9200df_defconfig (renamed from target/device/Atmel/at91rm9200df/at91rm9200df_defconfig)0
-rw-r--r--configs/at91rm9200df_ext_bare_defconfig (renamed from target/device/Atmel/at91rm9200df/at91rm9200df_ext_bare_defconfig)0
-rw-r--r--configs/at91rm9200df_ext_defconfig (renamed from target/device/Atmel/at91rm9200df/at91rm9200df_ext_defconfig)0
-rw-r--r--configs/at91sam9260dfc_defconfig (renamed from target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig)0
-rw-r--r--configs/at91sam9260dfc_ext_bare_defconfig (renamed from target/device/Atmel/at91sam9260dfc/at91sam9260dfc_ext_bare_defconfig)0
-rw-r--r--configs/at91sam9260dfc_ext_defconfig (renamed from target/device/Atmel/at91sam9260dfc/at91sam9260dfc_ext_defconfig)0
-rw-r--r--configs/at91sam9260pf_defconfig (renamed from target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig)0
-rw-r--r--configs/at91sam9261ek_defconfig (renamed from target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig)0
-rw-r--r--configs/at91sam9261ek_ext_bare_defconfig (renamed from target/device/Atmel/at91sam9261ek/at91sam9261ek_ext_bare_defconfig)0
-rw-r--r--configs/at91sam9261ek_ext_defconfig (renamed from target/device/Atmel/at91sam9261ek/at91sam9261ek_ext_defconfig)0
-rw-r--r--configs/at91sam9263ek_defconfig (renamed from target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig)0
-rw-r--r--configs/at91sam9263ek_ext_bare_defconfig (renamed from target/device/Atmel/at91sam9263ek/at91sam9263ek_ext_bare_defconfig)0
-rw-r--r--configs/at91sam9263ek_ext_defconfig (renamed from target/device/Atmel/at91sam9263ek/at91sam9263ek_ext_defconfig)0
-rw-r--r--configs/at91sam9g20dfc_defconfig (renamed from target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig)0
-rw-r--r--configs/at91sam9g20dfc_ext_bare_defconfig (renamed from target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_ext_bare_defconfig)0
-rw-r--r--configs/at91sam9g20dfc_ext_defconfig (renamed from target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_ext_defconfig)0
-rw-r--r--configs/atngw100-base_defconfig (renamed from target/device/Atmel/atngw100-base/atngw100-base_defconfig)0
-rw-r--r--configs/atngw100_defconfig (renamed from target/device/Atmel/atngw100/atngw100_defconfig)0
-rw-r--r--configs/atstk1005_defconfig (renamed from target/device/Atmel/atstk1005/atstk1005_defconfig)0
-rw-r--r--configs/atstk100x_defconfig (renamed from target/device/Atmel/atstk100x/atstk100x_defconfig)0
-rw-r--r--configs/i386_defconfig (renamed from target/device/x86/i686/i386_defconfig)0
-rw-r--r--configs/i686_defconfig (renamed from target/device/x86/i686/i686_defconfig)0
-rw-r--r--configs/integrator926_defconfig (renamed from target/device/ARMLTD/integrator926/integrator926_defconfig)0
-rw-r--r--configs/integrator926_huge_defconfig (renamed from target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig)0
-rw-r--r--configs/kb9202_defconfig (renamed from target/device/KwikByte/kb9202/kb9202_defconfig)0
-rw-r--r--configs/v100sc2_defconfig (renamed from target/device/valka/v100sc2_defconfig)0
-rw-r--r--docs/buildroot.html25
29 files changed, 15 insertions, 19 deletions
diff --git a/Makefile b/Makefile
index 5497c9b45..bbd49d415 100644
--- a/Makefile
+++ b/Makefile
@@ -591,9 +591,9 @@ endif # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
flush:
rm -f $(BUILD_DIR)/tgt-config.cache
-%_defconfig: $(CONFIG)/conf
- cp $(shell find ./target/ -name $@) .config
- -@$(MAKE) oldconfig
+%_defconfig: $(TOPDIR)/configs/%_defconfig
+ cp $^ .config
+ @$(MAKE) oldconfig
configured: dirs host-sed kernel-headers uclibc-config busybox-config linux26-config
@@ -628,6 +628,9 @@ help:
@echo ' external-deps - list external packages used'
@echo ' flush - flush configuration cache'
@echo
+ @$(foreach b, $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig)), \
+ printf " %-35s - Build for %s\\n" $(b) $(b:_defconfig=);)
+ @echo
@echo 'See docs/README and docs/buildroot.html for further details'
@echo
diff --git a/target/device/Atmel/at91sam9260dfc/arm_toolchain_defconfig b/configs/arm_toolchain_defconfig
index 1c59ae5de..1c59ae5de 100644
--- a/target/device/Atmel/at91sam9260dfc/arm_toolchain_defconfig
+++ b/configs/arm_toolchain_defconfig
diff --git a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig b/configs/at91rm9200df_defconfig
index 0f584fc95..0f584fc95 100644
--- a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
+++ b/configs/at91rm9200df_defconfig
diff --git a/target/device/Atmel/at91rm9200df/at91rm9200df_ext_bare_defconfig b/configs/at91rm9200df_ext_bare_defconfig
index 48b7eb5ad..48b7eb5ad 100644
--- a/target/device/Atmel/at91rm9200df/at91rm9200df_ext_bare_defconfig
+++ b/configs/at91rm9200df_ext_bare_defconfig
diff --git a/target/device/Atmel/at91rm9200df/at91rm9200df_ext_defconfig b/configs/at91rm9200df_ext_defconfig
index 33174ae0e..33174ae0e 100644
--- a/target/device/Atmel/at91rm9200df/at91rm9200df_ext_defconfig
+++ b/configs/at91rm9200df_ext_defconfig
diff --git a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig b/configs/at91sam9260dfc_defconfig
index 1d7e10f52..1d7e10f52 100644
--- a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
+++ b/configs/at91sam9260dfc_defconfig
diff --git a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_ext_bare_defconfig b/configs/at91sam9260dfc_ext_bare_defconfig
index 6620faf0e..6620faf0e 100644
--- a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_ext_bare_defconfig
+++ b/configs/at91sam9260dfc_ext_bare_defconfig
diff --git a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_ext_defconfig b/configs/at91sam9260dfc_ext_defconfig
index 4579b4602..4579b4602 100644
--- a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_ext_defconfig
+++ b/configs/at91sam9260dfc_ext_defconfig
diff --git a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig b/configs/at91sam9260pf_defconfig
index d9fadb7a1..d9fadb7a1 100644
--- a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
+++ b/configs/at91sam9260pf_defconfig
diff --git a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig b/configs/at91sam9261ek_defconfig
index ef1e44de8..ef1e44de8 100644
--- a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
+++ b/configs/at91sam9261ek_defconfig
diff --git a/target/device/Atmel/at91sam9261ek/at91sam9261ek_ext_bare_defconfig b/configs/at91sam9261ek_ext_bare_defconfig
index 03c2acbe6..03c2acbe6 100644
--- a/target/device/Atmel/at91sam9261ek/at91sam9261ek_ext_bare_defconfig
+++ b/configs/at91sam9261ek_ext_bare_defconfig
diff --git a/target/device/Atmel/at91sam9261ek/at91sam9261ek_ext_defconfig b/configs/at91sam9261ek_ext_defconfig
index 1bd143cd1..1bd143cd1 100644
--- a/target/device/Atmel/at91sam9261ek/at91sam9261ek_ext_defconfig
+++ b/configs/at91sam9261ek_ext_defconfig
diff --git a/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig b/configs/at91sam9263ek_defconfig
index 7ea6a992d..7ea6a992d 100644
--- a/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig
+++ b/configs/at91sam9263ek_defconfig
diff --git a/target/device/Atmel/at91sam9263ek/at91sam9263ek_ext_bare_defconfig b/configs/at91sam9263ek_ext_bare_defconfig
index 7ba1eed7e..7ba1eed7e 100644
--- a/target/device/Atmel/at91sam9263ek/at91sam9263ek_ext_bare_defconfig
+++ b/configs/at91sam9263ek_ext_bare_defconfig
diff --git a/target/device/Atmel/at91sam9263ek/at91sam9263ek_ext_defconfig b/configs/at91sam9263ek_ext_defconfig
index 3fd7a36ed..3fd7a36ed 100644
--- a/target/device/Atmel/at91sam9263ek/at91sam9263ek_ext_defconfig
+++ b/configs/at91sam9263ek_ext_defconfig
diff --git a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig b/configs/at91sam9g20dfc_defconfig
index 30a2e4c51..30a2e4c51 100644
--- a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig
+++ b/configs/at91sam9g20dfc_defconfig
diff --git a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_ext_bare_defconfig b/configs/at91sam9g20dfc_ext_bare_defconfig
index 63e166db3..63e166db3 100644
--- a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_ext_bare_defconfig
+++ b/configs/at91sam9g20dfc_ext_bare_defconfig
diff --git a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_ext_defconfig b/configs/at91sam9g20dfc_ext_defconfig
index 19ab32489..19ab32489 100644
--- a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_ext_defconfig
+++ b/configs/at91sam9g20dfc_ext_defconfig
diff --git a/target/device/Atmel/atngw100-base/atngw100-base_defconfig b/configs/atngw100-base_defconfig
index 0e0b78dca..0e0b78dca 100644
--- a/target/device/Atmel/atngw100-base/atngw100-base_defconfig
+++ b/configs/atngw100-base_defconfig
diff --git a/target/device/Atmel/atngw100/atngw100_defconfig b/configs/atngw100_defconfig
index ba30c1328..ba30c1328 100644
--- a/target/device/Atmel/atngw100/atngw100_defconfig
+++ b/configs/atngw100_defconfig
diff --git a/target/device/Atmel/atstk1005/atstk1005_defconfig b/configs/atstk1005_defconfig
index 99b740a81..99b740a81 100644
--- a/target/device/Atmel/atstk1005/atstk1005_defconfig
+++ b/configs/atstk1005_defconfig
diff --git a/target/device/Atmel/atstk100x/atstk100x_defconfig b/configs/atstk100x_defconfig
index 7b6d42600..7b6d42600 100644
--- a/target/device/Atmel/atstk100x/atstk100x_defconfig
+++ b/configs/atstk100x_defconfig
diff --git a/target/device/x86/i686/i386_defconfig b/configs/i386_defconfig
index 2df16efdf..2df16efdf 100644
--- a/target/device/x86/i686/i386_defconfig
+++ b/configs/i386_defconfig
diff --git a/target/device/x86/i686/i686_defconfig b/configs/i686_defconfig
index af0cc158f..af0cc158f 100644
--- a/target/device/x86/i686/i686_defconfig
+++ b/configs/i686_defconfig
diff --git a/target/device/ARMLTD/integrator926/integrator926_defconfig b/configs/integrator926_defconfig
index 9531f1cd1..9531f1cd1 100644
--- a/target/device/ARMLTD/integrator926/integrator926_defconfig
+++ b/configs/integrator926_defconfig
diff --git a/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig b/configs/integrator926_huge_defconfig
index 805ac0f0b..805ac0f0b 100644
--- a/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig
+++ b/configs/integrator926_huge_defconfig
diff --git a/target/device/KwikByte/kb9202/kb9202_defconfig b/configs/kb9202_defconfig
index ce50f2c2a..ce50f2c2a 100644
--- a/target/device/KwikByte/kb9202/kb9202_defconfig
+++ b/configs/kb9202_defconfig
diff --git a/target/device/valka/v100sc2_defconfig b/configs/v100sc2_defconfig
index f444951ae..f444951ae 100644
--- a/target/device/valka/v100sc2_defconfig
+++ b/configs/v100sc2_defconfig
diff --git a/docs/buildroot.html b/docs/buildroot.html
index 45876d7b6..2fc752812 100644
--- a/docs/buildroot.html
+++ b/docs/buildroot.html
@@ -646,22 +646,15 @@ endif
<li>Then, in the
<code>target/device/yourcompany/project-foobar/</code>
- directory, you can store different files:
-
- <ul>
-
- <li>One or more Buildroot configurations, under file named
- <code>something_defconfig</code>. Your users will then be able
- to run <code>make something_defconfig</code> and get the right
- configuration for your project</li>
-
- <li>Configuration files for the kernel, for Busybox or
- uClibc. These files can then be referenced by the Buildroot
- configuration described above</li>
-
- </ul>
-
- </li>
+ directory, you can store configuration files for the kernel,
+ for Busybox or uClibc.
+
+ You can furthermore create one or more preconfigured configuration
+ files, referencing those files. These config files are named
+ <code>something_defconfig</config> and are stored in the toplevel
+ <code>configs/</code> directory. Your users will then be able
+ to run <code>make something_defconfig</code> and get the right
+ configuration for your project</li>
</ol>