summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Makefile.autotools.in3
-rw-r--r--project/Makefile.in11
2 files changed, 7 insertions, 7 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 9f7a54807..1a38d4ffb 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -225,8 +225,7 @@ $(BUILD_DIR)/%/.stamp_configured:
--prefix=/usr \
--exec-prefix=/usr \
--sysconfdir=/etc \
- $(if $(findstring s,$(MAKEFLAGS)),--quiet,) \
- $($(PKG)_CONF_OPT)
+ $(QUIET) $($(PKG)_CONF_OPT)
$(Q)touch $@
# Build
diff --git a/project/Makefile.in b/project/Makefile.in
index cc1043ba1..fc73e407b 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -5,17 +5,19 @@ TARGET_HOSTNAME:=$(strip $(subst ",,$(BR2_HOSTNAME)))
BANNER:=$(strip $(subst ",,$(BR2_BANNER)))
#"))
+# silent mode requested?
+QUIET:=$(if $(findstring s,$(MAKEFLAGS)),-q,)
# Strip off the annoying quoting
ARCH:=$(strip $(subst ",, $(BR2_ARCH)))
#"))
-WGET:=$(strip $(subst ",, $(BR2_WGET))) $(SPIDER)
+WGET:=$(strip $(subst ",, $(BR2_WGET))) $(SPIDER) $(QUIET)
#"))
-SVN_CO:=$(strip $(subst ",, $(BR2_SVN_CO)))
+SVN_CO:=$(strip $(subst ",, $(BR2_SVN_CO))) $(QUIET)
#"))
-SVN_UP:=$(strip $(subst ",, $(BR2_SVN_UP)))
+SVN_UP:=$(strip $(subst ",, $(BR2_SVN_UP))) $(QUIET)
#"))
-GIT:=$(strip $(subst ",, $(BR2_GIT)))
+GIT:=$(strip $(subst ",, $(BR2_GIT))) $(QUIET)
#"))
ZCAT:=$(strip $(subst ",, $(BR2_ZCAT)))
#"))
@@ -24,7 +26,6 @@ BZCAT:=$(strip $(subst ",, $(BR2_BZCAT)))
TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
#")
-
# Buildroot supports building out of tree similarly to the Linux kernel.
# To use, add O= to the make command line (make O=/tmp/build)
BASE_DIR:=$(shell pwd)