summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/coreutils/Config.in1
-rw-r--r--package/tar/Config.in1
-rw-r--r--toolchain/uClibc/Config.in9
-rw-r--r--toolchain/uClibc/uclibc.mk5
4 files changed, 16 insertions, 0 deletions
diff --git a/package/coreutils/Config.in b/package/coreutils/Config.in
index 4722664ad..adc3782c1 100644
--- a/package/coreutils/Config.in
+++ b/package/coreutils/Config.in
@@ -2,6 +2,7 @@ config BR2_PACKAGE_COREUTILS
bool "coreutils"
default n
depends on BR2_USE_WCHAR
+ select BR2_UCLIBC_PROGRAM_INVOCATION
help
All of the basic file/text/shell utilities. These are the
core utilities which are expected to exist on every system.
diff --git a/package/tar/Config.in b/package/tar/Config.in
index c334c3ffa..9116e2943 100644
--- a/package/tar/Config.in
+++ b/package/tar/Config.in
@@ -2,6 +2,7 @@ config BR2_PACKAGE_TAR
bool "tar"
default n
depends on BR2_USE_WCHAR
+ select BR2_UCLIBC_PROGRAM_INVOCATION
help
A program that saves many files together into a single tape or disk
archive, and can restore individual files from the archive.
diff --git a/toolchain/uClibc/Config.in b/toolchain/uClibc/Config.in
index a43161ca7..455731c70 100644
--- a/toolchain/uClibc/Config.in
+++ b/toolchain/uClibc/Config.in
@@ -82,3 +82,12 @@ config BR2_PTHREAD_DEBUG
default n
help
Build the thread library with debugging enabled.
+
+config BR2_UCLIBC_PROGRAM_INVOCATION
+ bool "Enable 'program invocation name'"
+ default n
+ help
+ Support for the GNU-specific program_invocation_name and
+ program_invocation_short_name strings. Some GNU packages
+ (like tar and coreutils) utilize these for extra useful
+ output, but in general are not required.
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index ebcc56862..395558f9b 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -229,6 +229,11 @@ ifeq ($(BR2_USE_WCHAR),y)
else
$(SED) 's,^.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=n,g' $(UCLIBC_DIR)/.oldconfig
endif
+ifeq ($(BR2_UCLIBC_PROGRAM_INVOCATION),y)
+ echo "UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y" >> $(UCLIBC_DIR)/.oldconfig
+else
+ echo "# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set" >> $(UCLIBC_DIR)/.oldconfig
+endif
ifeq ("$(KERNEL_ARCH)","i386")
/bin/echo "# CONFIG_GENERIC_386 is not set" >> $(UCLIBC_DIR)/.oldconfig
/bin/echo "# CONFIG_386 is not set" >> $(UCLIBC_DIR)/.oldconfig