summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/pcre/Config.in5
-rw-r--r--package/pcre/pcre.mk18
3 files changed, 24 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index eddde49e9..53d312c50 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -56,6 +56,7 @@ source "package/oprofile/Config.in"
source "package/pkgconfig/Config.in"
source "package/readline/Config.in"
source "package/valgrind/Config.in"
+source "package/pcre/Config.in"
comment "Other stuff"
source "package/at/Config.in"
diff --git a/package/pcre/Config.in b/package/pcre/Config.in
new file mode 100644
index 000000000..d26a2715a
--- /dev/null
+++ b/package/pcre/Config.in
@@ -0,0 +1,5 @@
+config BR2_PACKAGE_PCRE
+ bool "pcre"
+ default n
+ help
+ Perl Compatible Regular Expressions
diff --git a/package/pcre/pcre.mk b/package/pcre/pcre.mk
new file mode 100644
index 000000000..f6f7003d0
--- /dev/null
+++ b/package/pcre/pcre.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# PCRE
+#
+#############################################################
+PCRE_VERSION = 7.6
+PCRE_SOURCE = pcre-$(PCRE_VERSION).tar.bz2
+PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
+PCRE_INSTALL_STAGING = YES
+PCRE_INSTALL_TARGET = YES
+
+PCRE_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) --prefix=/usr \
+ --includedir=/usr/include
+
+PCRE_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,pcre))