summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in4
-rw-r--r--toolchain/elf2flt/elf2flt.mk4
2 files changed, 4 insertions, 4 deletions
diff --git a/Config.in b/Config.in
index 31cb70f09..ee7a45134 100644
--- a/Config.in
+++ b/Config.in
@@ -243,14 +243,14 @@ choice
config BR2_STRIP_strip
bool "strip"
- depends on !BR2_ENABLE_DEBUG
+ depends on !BR2_ENABLE_DEBUG && !BR2_ELF2FLT
help
strip is the normal strip command
config BR2_STRIP_sstrip
bool "sstrip"
select BR2_PACKAGE_SSTRIP_HOST
- depends on !BR2_ENABLE_DEBUG
+ depends on !BR2_ENABLE_DEBUG && !BR2_ELF2FLT
help
sstrip is a strip that discards more than the normal strip
diff --git a/toolchain/elf2flt/elf2flt.mk b/toolchain/elf2flt/elf2flt.mk
index 30d7e839a..f5a92b1f2 100644
--- a/toolchain/elf2flt/elf2flt.mk
+++ b/toolchain/elf2flt/elf2flt.mk
@@ -27,11 +27,11 @@ $(ELF2FLT_DIR)/.configured: $(ELF2FLT_DIR)/.patched
LDFLAGS=-lz \
$(ELF2FLT_DIR)/configure \
--with-bfd-include-dir=$(BINUTILS_DIR1)/bfd/ \
- --with-binutils-include-dir=$(BINUTILS_DIR)/include/ \
+ --with-binutils-include-dir=$(BINUTILS_DIR)/include/ \
--target=$(REAL_GNU_TARGET_NAME) \
--with-libbfd=$(BINUTILS_DIR1)/bfd/libbfd.a \
--with-libiberty=$(BINUTILS_DIR1)/libiberty/libiberty.a \
- --prefix=$(STAGING_DIR))
+ --prefix=$(STAGING_DIR)/usr)
touch $@
$(ELF2FLT_DIR)/$(ELF2FLT_BINARY): $(ELF2FLT_DIR)/.configured