summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/neon/neon.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 750217acc..543a47c6b 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -27,3 +27,8 @@ NEON_CONF_OPT+=--disable-webdav
endif
$(eval $(call AUTOTARGETS,package,neon))
+
+# neon doesn't have an install-strip target, so do it afterwards
+$(NEON_HOOK_POST_INSTALL): $(NEON_TARGET_INSTALL_TARGET)
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libneon.so
+ touch $@