summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--fs/Config.in23
2 files changed, 27 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 59151cc2f..744cae445 100644
--- a/Makefile
+++ b/Makefile
@@ -367,6 +367,10 @@ $(STAGING_DIR):
@mkdir -p $(STAGING_DIR)/usr/include
@mkdir -p $(STAGING_DIR)/usr/bin
+ifeq ($(BR2_ROOTFS_SKELETON_CUSTOM),y)
+TARGET_SKELETON=$(BR2_ROOTFS_SKELETON_CUSTOM_PATH)
+endif
+
$(BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
if ! [ -d "$(TARGET_DIR)/bin" ]; then \
diff --git a/fs/Config.in b/fs/Config.in
index 6865eeaff..188e8155b 100644
--- a/fs/Config.in
+++ b/fs/Config.in
@@ -23,6 +23,29 @@ config BR2_ROOTFS_DEVICE_TABLE
to the makedevs utility to create all the special device
files in the target filesystem.
+choice
+ prompt "Root FS skeleton"
+
+config BR2_ROOTFS_SKELETON_DEFAULT
+ bool "default target skeleton"
+ help
+ Use default target skeleton
+
+config BR2_ROOTFS_SKELETON_CUSTOM
+ bool "custom target skeleton"
+ help
+ Use custom target skeleton.
+
+endchoice
+
+if BR2_ROOTFS_SKELETON_CUSTOM
+config BR2_ROOTFS_SKELETON_CUSTOM_PATH
+ string "custom target skeleton path"
+ default "fs/skeleton"
+ help
+ Path custom target skeleton.
+endif
+
source "fs/cramfs/Config.in"
source "fs/cloop/Config.in"
source "fs/ext2/Config.in"