summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 1fc51e9cb..6f8ed0e29 100644
--- a/Makefile
+++ b/Makefile
@@ -392,9 +392,11 @@ $(BUILD_DIR)/buildroot-config/auto.conf: $(BUILDROOT_CONFIG)
prepare: $(BUILD_DIR)/buildroot-config/auto.conf
-world: prepare dirs dependencies $(BASE_TARGETS) $(TARGETS_ALL)
+toolchain: prepare dirs dependencies $(BASE_TARGETS)
-.PHONY: all world dirs clean distclean source outputmakefile \
+world: toolchain $(TARGETS_ALL)
+
+.PHONY: all world toolchain dirs clean distclean source outputmakefile \
legal-info legal-info-prepare legal-info-clean \
$(BASE_TARGETS) $(TARGETS) $(TARGETS_ALL) \
$(TARGETS_CLEAN) $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) $(TARGETS_LEGAL_INFO) \
@@ -715,8 +717,6 @@ ifeq ($(O),output)
endif
rm -rf $(BUILDROOT_CONFIG) $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/.auto.deps
-cross: $(BASE_TARGETS)
-
help:
@echo 'Cleaning:'
@echo ' clean - delete all files created by build'
@@ -724,6 +724,7 @@ help:
@echo
@echo 'Build:'
@echo ' all - make world'
+ @echo ' toolchain - build toolchain'
@echo ' <package>-rebuild - force recompile <package>'
@echo ' <package>-reconfigure - force reconfigure <package>'
@echo