summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/openssh/openssh.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/openssh/openssh.mk b/package/openssh/openssh.mk
index 64274e5a1..17044ccb5 100644
--- a/package/openssh/openssh.mk
+++ b/package/openssh/openssh.mk
@@ -14,8 +14,10 @@ OPENSSH_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
OPENSSH_DEPENDENCIES = zlib openssl
-$(eval $(call AUTOTARGETS,package,openssh))
-
-$(OPENSSH_HOOK_POST_INSTALL):
+define OPENSSH_INSTALL_INITSCRIPT
$(INSTALL) -D -m 755 package/openssh/S50sshd $(TARGET_DIR)/etc/init.d/S50sshd
- touch $@
+endef
+
+OPENSSH_POST_INSTALL_TARGET_HOOKS += OPENSSH_INSTALL_INITSCRIPT
+
+$(eval $(call AUTOTARGETS,package,openssh))