summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in.legacy26
-rw-r--r--package/Config.in2
-rw-r--r--package/gdisk/gdisk.mk39
-rw-r--r--package/gptfdisk/Config.in (renamed from package/gdisk/Config.in)14
-rw-r--r--package/gptfdisk/gptfdisk-001-no-utf16.patch (renamed from package/gdisk/gdisk-001-no-utf16.patch)0
-rw-r--r--package/gptfdisk/gptfdisk.mk38
6 files changed, 72 insertions, 47 deletions
diff --git a/Config.in.legacy b/Config.in.legacy
index d90132c53..43e2afe8e 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -40,6 +40,32 @@ comment "As long as these options stay selected, the build "
comment "will fail. "
endif
+#
+# Legacy options since 2013.02
+#
+
+config BR2_PACKAGE_GDISK
+ bool "gdisk has been replaced by gptfdisk"
+ select BR2_LEGACY
+ select BR2_PACKAGE_GPTFDISK
+ help
+ The option has been renamed BR2_PACKAGE_GPTFDISK.
+
+config BR2_PACKAGE_GDISK_GDISK
+ bool "gdisk tool from gdisk has been replaced by gdisk in gptfdisk"
+ select BR2_LEGACY
+ select BR2_PACKAGE_GPTFDISK
+ select BR2_PACKAGE_GPTFDISK_GDISK
+ help
+ The option has been renamed BR2_PACKAGE_GPTFDISK_GDISK.
+
+config BR2_PACKAGE_GDISK_SGDISK
+ bool "sgdisk tool from gdisk has been replaced by sgdisk in gptfdisk"
+ select BR2_LEGACY
+ select BR2_PACKAGE_GPTFDISK
+ select BR2_PACKAGE_GPTFDISK_SGDISK
+ help
+ The option has been renamed BR2_PACKAGE_GPTFDISK_SGDISK.
#
# Legacy options since 2012.11
diff --git a/package/Config.in b/package/Config.in
index 22e64f869..6458b6eca 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -235,8 +235,8 @@ source "package/fis/Config.in"
source "package/fmtools/Config.in"
source "package/fxload/Config.in"
source "package/gadgetfs-test/Config.in"
-source "package/gdisk/Config.in"
source "package/gpsd/Config.in"
+source "package/gptfdisk/Config.in"
source "package/gvfs/Config.in"
if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
source "package/hdparm/Config.in"
diff --git a/package/gdisk/gdisk.mk b/package/gdisk/gdisk.mk
deleted file mode 100644
index cda369ede..000000000
--- a/package/gdisk/gdisk.mk
+++ /dev/null
@@ -1,39 +0,0 @@
-#############################################################
-#
-# gdisk
-#
-#############################################################
-
-GDISK_VERSION = 0.8.6
-GDISK_SITE = http://downloads.sourceforge.net/sourceforge/gptfdisk
-GDISK_SOURCE = gptfdisk-$(GDISK_VERSION).tar.gz
-
-GDISK_TARGETS_$(BR2_PACKAGE_GDISK_GDISK) += gdisk
-GDISK_TARGETS_$(BR2_PACKAGE_GDISK_SGDISK) += sgdisk
-
-ifneq ($(GDISK_TARGETS_y),)
-
-GDISK_DEPENDENCIES += util-linux
-ifeq ($(BR2_PACKAGE_GDISK_SGDISK),y)
- GDISK_DEPENDENCIES += popt
-endif
-
-
-define GDISK_BUILD_CMDS
- $(TARGET_CONFIGURE_OPTS) $(MAKE) CC="$(TARGET_CC)" CXX="$(TARGET_CXX)" \
- -C $(@D) $(GDISK_TARGETS_y)
-endef
-
-define GDISK_INSTALL_TARGET_CMDS
- for i in $(GDISK_TARGETS_y); do \
- $(INSTALL) -D $(@D)/$$i $(TARGET_DIR)/usr/sbin/; \
- done
-endef
-
-define GDISK_UNINSTALL_TARGET_CMDS
- rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,$(GDISK_TARGETS_y))
-endef
-
-endif
-
-$(eval $(generic-package))
diff --git a/package/gdisk/Config.in b/package/gptfdisk/Config.in
index 24d305d1f..7851dc3dc 100644
--- a/package/gdisk/Config.in
+++ b/package/gptfdisk/Config.in
@@ -1,5 +1,5 @@
-config BR2_PACKAGE_GDISK
- bool "gdisk"
+config BR2_PACKAGE_GPTFDISK
+ bool "gptfdisk"
depends on BR2_LARGEFILE
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_USE_WCHAR # util-linux
@@ -11,9 +11,9 @@ config BR2_PACKAGE_GDISK
http://www.rodsbooks.com/gdisk/
-config BR2_PACKAGE_GDISK_GDISK
+config BR2_PACKAGE_GPTFDISK_GDISK
bool "interactive gdisk"
- depends on BR2_PACKAGE_GDISK
+ depends on BR2_PACKAGE_GPTFDISK
select BR2_PACKAGE_UTIL_LINUX
select BR2_PACKAGE_UTIL_LINUX_LIBUUID
help
@@ -21,9 +21,9 @@ config BR2_PACKAGE_GDISK_GDISK
/usr/sbin/gdisk which is modelled after and quite similar in use
to the traditional MBR based fdisk tool.
-config BR2_PACKAGE_GDISK_SGDISK
+config BR2_PACKAGE_GPTFDISK_SGDISK
bool "command line sgdisk"
- depends on BR2_PACKAGE_GDISK
+ depends on BR2_PACKAGE_GPTFDISK
select BR2_PACKAGE_UTIL_LINUX
select BR2_PACKAGE_UTIL_LINUX_LIBUUID
select BR2_PACKAGE_POPT
@@ -32,5 +32,5 @@ config BR2_PACKAGE_GDISK_SGDISK
/usr/sbin/sgdisk which is named after the traditional MBR based
sfdisk tool albeit with an entirely different option syntax.
-comment "gdisk requires a toolchain with LARGEFILE/WCHAR/C++ support enabled"
+comment "gptfdisk requires a toolchain with LARGEFILE/WCHAR/C++ support enabled"
depends on !(BR2_LARGEFILE && BR2_INSTALL_LIBSTDCPP && BR2_USE_WCHAR)
diff --git a/package/gdisk/gdisk-001-no-utf16.patch b/package/gptfdisk/gptfdisk-001-no-utf16.patch
index 540e74190..540e74190 100644
--- a/package/gdisk/gdisk-001-no-utf16.patch
+++ b/package/gptfdisk/gptfdisk-001-no-utf16.patch
diff --git a/package/gptfdisk/gptfdisk.mk b/package/gptfdisk/gptfdisk.mk
new file mode 100644
index 000000000..7755a30c9
--- /dev/null
+++ b/package/gptfdisk/gptfdisk.mk
@@ -0,0 +1,38 @@
+#############################################################
+#
+# gptfdisk
+#
+#############################################################
+
+GPTFDISK_VERSION = 0.8.6
+GPTFDISK_SITE = http://downloads.sourceforge.net/sourceforge/gptfdisk
+
+GPTFDISK_TARGETS_$(BR2_PACKAGE_GPTFDISK_GDISK) += gdisk
+GPTFDISK_TARGETS_$(BR2_PACKAGE_GPTFDISK_SGDISK) += sgdisk
+
+ifneq ($(GPTFDISK_TARGETS_y),)
+
+GPTFDISK_DEPENDENCIES += util-linux
+ifeq ($(BR2_PACKAGE_GPTFDISK_SGDISK),y)
+ GPTFDISK_DEPENDENCIES += popt
+endif
+
+
+define GPTFDISK_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) CC="$(TARGET_CC)" CXX="$(TARGET_CXX)" \
+ -C $(@D) $(GPTFDISK_TARGETS_y)
+endef
+
+define GPTFDISK_INSTALL_TARGET_CMDS
+ for i in $(GPTFDISK_TARGETS_y); do \
+ $(INSTALL) -D $(@D)/$$i $(TARGET_DIR)/usr/sbin/; \
+ done
+endef
+
+define GPTFDISK_UNINSTALL_TARGET_CMDS
+ rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,$(GPTFDISK_TARGETS_y))
+endef
+
+endif
+
+$(eval $(generic-package))