summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/grep/grep.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index e323b1de9..bfc911663 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -9,4 +9,10 @@ GREP_SITE = $(BR2_GNU_MIRROR)/grep
GREP_CONF_OPT = --disable-perl-regexp --without-included-regex
GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
+# link with iconv if enabled
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+GREP_CONF_ENV += LIBS=-liconv
+GREP_DEPENDENCIES += libiconv
+endif
+
$(eval $(call AUTOTARGETS,package,grep))