summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/efl/Config.in1
-rw-r--r--package/efl/libembryo/Config.in9
-rw-r--r--package/efl/libembryo/libembryo.mk15
3 files changed, 25 insertions, 0 deletions
diff --git a/package/efl/Config.in b/package/efl/Config.in
index 300778398..0e27dab7e 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -12,6 +12,7 @@ source "package/efl/libeina/Config.in"
source "package/efl/libecore/Config.in"
source "package/efl/libeet/Config.in"
source "package/efl/libevas/Config.in"
+source "package/efl/libembryo/Config.in"
endif # BR2_PACKAGE_EFL
diff --git a/package/efl/libembryo/Config.in b/package/efl/libembryo/Config.in
new file mode 100644
index 000000000..63c706415
--- /dev/null
+++ b/package/efl/libembryo/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBEMBRYO
+ bool "libembryo"
+ select BR2_PACKAGE_LIBEINA
+ help
+ Embryo is primarily a shared library that gives you an API
+ to load and control interpreted programs compiled into an
+ abstract machine bytecode that it understands.
+
+ http://trac.enlightenment.org/e/wiki/Embryo
diff --git a/package/efl/libembryo/libembryo.mk b/package/efl/libembryo/libembryo.mk
new file mode 100644
index 000000000..0054ff41c
--- /dev/null
+++ b/package/efl/libembryo/libembryo.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# libembryo
+#
+#############################################################
+
+LIBEMBRYO_VERSION = 1.1.0
+LIBEMBRYO_SOURCE = embryo-$(LIBEMBRYO_VERSION).tar.bz2
+LIBEMBRYO_SITE = http://download.enlightenment.org/releases/
+LIBEMBRYO_INSTALL_STAGING = YES
+
+LIBEMBRYO_DEPENDENCIES = host-pkg-config libeina
+
+$(eval $(call AUTOTARGETS))
+$(eval $(call AUTOTARGETS,host))