summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/gptfdisk/Config.in11
-rw-r--r--package/gptfdisk/gptfdisk.mk4
2 files changed, 14 insertions, 1 deletions
diff --git a/package/gptfdisk/Config.in b/package/gptfdisk/Config.in
index 0d7e35836..28b20df04 100644
--- a/package/gptfdisk/Config.in
+++ b/package/gptfdisk/Config.in
@@ -5,7 +5,8 @@ config BR2_PACKAGE_GPTFDISK
depends on BR2_USE_WCHAR # util-linux
select BR2_PACKAGE_UTIL_LINUX
select BR2_PACKAGE_UTIL_LINUX_LIBUUID
- select BR2_PACKAGE_GPTFDISK_GDISK if !BR2_PACKAGE_GPTFDISK_SGDISK
+ select BR2_PACKAGE_GPTFDISK_GDISK if \
+ !(BR2_PACKAGE_GPTFDISK_SGDISK || BR2_PACKAGE_GPTFDISK_CGDISK)
help
GPT fdisk (consisting of the gdisk and sgdisk programs) is a
text-mode partitioning tool that works on Globally Unique Identifier
@@ -31,5 +32,13 @@ config BR2_PACKAGE_GPTFDISK_SGDISK
/usr/sbin/sgdisk which is named after the traditional MBR based
sfdisk tool albeit with an entirely different option syntax.
+config BR2_PACKAGE_GPTFDISK_CGDISK
+ bool "ncurses cgdisk"
+ depends on BR2_PACKAGE_GPTFDISK
+ select BR2_PACKAGE_NCURSES
+ help
+ Install the ncurses-based GUID partition table (GPT)
+ manipulator /usr/sbin/cgdisk.
+
comment "gptfdisk requires a toolchain with LARGEFILE/WCHAR/C++ support enabled"
depends on !(BR2_LARGEFILE && BR2_INSTALL_LIBSTDCPP && BR2_USE_WCHAR)
diff --git a/package/gptfdisk/gptfdisk.mk b/package/gptfdisk/gptfdisk.mk
index 0478041d9..15ec842de 100644
--- a/package/gptfdisk/gptfdisk.mk
+++ b/package/gptfdisk/gptfdisk.mk
@@ -9,11 +9,15 @@ GPTFDISK_SITE = http://downloads.sourceforge.net/sourceforge/gptfdisk
GPTFDISK_TARGETS_$(BR2_PACKAGE_GPTFDISK_GDISK) += gdisk
GPTFDISK_TARGETS_$(BR2_PACKAGE_GPTFDISK_SGDISK) += sgdisk
+GPTFDISK_TARGETS_$(BR2_PACKAGE_GPTFDISK_CGDISK) += cgdisk
GPTFDISK_DEPENDENCIES += util-linux
ifeq ($(BR2_PACKAGE_GPTFDISK_SGDISK),y)
GPTFDISK_DEPENDENCIES += popt
endif
+ifeq ($(BR2_PACKAGE_GPTFDISK_CGDISK),y)
+ GPTFDISK_DEPENDENCIES += ncurses
+endif
ifeq ($(BR2_PACKAGE_ICU),y)
GPTFDISK_DEPENDENCIES += icu