summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/gcc/gcc.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/gcc/gcc.mk b/package/gcc/gcc.mk
index 790762da7..968354b41 100644
--- a/package/gcc/gcc.mk
+++ b/package/gcc/gcc.mk
@@ -38,8 +38,17 @@ endef
# Apply patches
#
+ifeq ($(ARCH)-$(BR2_GCC_SHARED_LIBGCC),powerpc-y)
+ifneq ($(BR2_SOFT_FLOAT),)
+define HOST_GCC_APPLY_POWERPC_PATCH
+ support/scripts/apply-patches.sh $(@D) package/gcc/$(GCC_VERSION) powerpc-link-with-math-lib.patch.conditional
+endef
+endif
+endif
+
define HOST_GCC_APPLY_PATCHES
support/scripts/apply-patches.sh $(@D) package/gcc/$(GCC_VERSION) \*.patch
+ $(HOST_GCC_APPLY_POWERPC_PATCH)
endef
#