summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/libexif/Config.in9
-rw-r--r--package/libexif/libexif.mk14
3 files changed, 24 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 46ecbcb32..71dc0a80a 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -275,6 +275,7 @@ source "package/gtk2-themes/Config.in"
source "package/jpeg/Config.in"
source "package/libart/Config.in"
source "package/libdrm/Config.in"
+source "package/libexif/Config.in"
source "package/libgail/Config.in"
source "package/libglade/Config.in"
source "package/gdk-pixbuf/Config.in"
diff --git a/package/libexif/Config.in b/package/libexif/Config.in
new file mode 100644
index 000000000..9c89df410
--- /dev/null
+++ b/package/libexif/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBEXIF
+ bool "libexif"
+ help
+ Most digital cameras produce EXIF files, which are JPEG
+ files with extra tags that contain information about the
+ image. The EXIF library allows you to parse an EXIF file
+ and read the data from those tags.
+
+ http://libexif.sf.net
diff --git a/package/libexif/libexif.mk b/package/libexif/libexif.mk
new file mode 100644
index 000000000..17c44aff9
--- /dev/null
+++ b/package/libexif/libexif.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# libexif
+#
+#############################################################
+
+LIBEXIF_VERSION = 0.6.20
+LIBEXIF_SOURCE = libexif-$(LIBEXIF_VERSION).tar.bz2
+LIBEXIF_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/project/libexif/libexif/$(LIBEXIF_VERSION)
+LIBEXIF_INSTALL_STAGING = YES
+LIBEXIF_CONF_OPT = --disable-docs
+LIBEXIF_DEPENDENCIES = host-pkg-config
+
+$(eval $(call AUTOTARGETS,package,libexif))