summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/lua-ev/Config.in7
-rw-r--r--package/lua-ev/lua-ev.mk14
3 files changed, 22 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 2d32a9ff1..92927e398 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -320,6 +320,7 @@ source "package/luacjson/Config.in"
source "package/luaexpat/Config.in"
source "package/luafilesystem/Config.in"
source "package/luasocket/Config.in"
+source "package/lua-ev/Config.in"
source "package/lua-msgpack-native/Config.in"
source "package/rings/Config.in"
source "package/wsapi/Config.in"
diff --git a/package/lua-ev/Config.in b/package/lua-ev/Config.in
new file mode 100644
index 000000000..1e89c270a
--- /dev/null
+++ b/package/lua-ev/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LUA_EV
+ bool "lua-ev"
+ select BR2_PACKAGE_LIBEV
+ help
+ Get access to the libev library from Lua.
+
+ https://github.com/brimworks/lua-ev
diff --git a/package/lua-ev/lua-ev.mk b/package/lua-ev/lua-ev.mk
new file mode 100644
index 000000000..2b03936c2
--- /dev/null
+++ b/package/lua-ev/lua-ev.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# lua-ev
+#
+################################################################################
+
+LUA_EV_VERSION = 458165b
+LUA_EV_SITE = http://github.com/brimworks/lua-ev/tarball/$(LUA_EV_VERSION)
+LUA_EV_DEPENDENCIES = lua libev
+LUA_EV_LICENSE = MIT
+LUA_EV_LICENSE_FILES = README
+LUA_EV_CONF_OPT = -DINSTALL_CMOD="/usr/lib/lua"
+
+$(eval $(cmake-package))