summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/hostapd/hostapd-0.7.3-libnl3.patch15
-rw-r--r--package/hostapd/hostapd.mk1
2 files changed, 16 insertions, 0 deletions
diff --git a/package/hostapd/hostapd-0.7.3-libnl3.patch b/package/hostapd/hostapd-0.7.3-libnl3.patch
new file mode 100644
index 000000000..e47da73dd
--- /dev/null
+++ b/package/hostapd/hostapd-0.7.3-libnl3.patch
@@ -0,0 +1,15 @@
+--- a/src/drivers/drivers.mak 2011-11-29 19:09:23.889942913 +0100
++++ b/src/drivers/drivers.mak 2011-11-29 19:09:40.637381428 +0100
+@@ -31,10 +31,10 @@
+ NEED_AP_MLME=y
+ NEED_NETLINK=y
+ NEED_LINUX_IOCTL=y
+-DRV_LIBS += -lnl
++DRV_LIBS += -lnl-3
+
+ ifdef CONFIG_LIBNL20
+-DRV_LIBS += -lnl-genl
++DRV_LIBS += -lnl-genl-3
+ DRV_CFLAGS += -DCONFIG_LIBNL20
+ endif
+ endif
diff --git a/package/hostapd/hostapd.mk b/package/hostapd/hostapd.mk
index 0d6c2c53a..26ebf1de0 100644
--- a/package/hostapd/hostapd.mk
+++ b/package/hostapd/hostapd.mk
@@ -18,6 +18,7 @@ endif
define HOSTAPD_LIBNL_CONFIG
echo "CONFIG_LIBNL20=y" >>$(HOSTAPD_CONFIG)
+ echo "CFLAGS += -I$(STAGING_DIR)/usr/include/libnl3/" >>$(HOSTAPD_CONFIG)
endef
define HOSTAPD_CRYPTO_CONFIG