summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-25 08:18:36 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-25 08:18:36 +0000
commitd8fc1c0a74b81009c855cc532432cdd3c8a47a7a (patch)
tree5aec45164836cd0ba4c1345d0cd42a5fd054d442 /toolchain
parentb5879204756c1dc70c137c65c8ddda7909643811 (diff)
downloadbuildroot-novena-d8fc1c0a74b81009c855cc532432cdd3c8a47a7a.tar.gz
buildroot-novena-d8fc1c0a74b81009c855cc532432cdd3c8a47a7a.zip
- remove one invariant in toolchain type selection.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in15
-rw-r--r--toolchain/binutils/binutils.mk4
-rw-r--r--toolchain/external-toolchain/Config.in7
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk4
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk4
-rw-r--r--toolchain/gdb/gdb.mk4
-rw-r--r--toolchain/uClibc/uclibc.mk4
7 files changed, 26 insertions, 16 deletions
diff --git a/toolchain/Config.in b/toolchain/Config.in
index 10a1be92d..0290cb927 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -3,16 +3,25 @@ choice
prompt "Toolchain type"
default BR2_TOOLCHAIN_BUILDROOT
help
- Select whether to use the toolchain built by the buildroot
- system or an external pre-built toolchain.
+ Select whether to use the toolchain provided by buildroot
+ or an external toolchain.
config BR2_TOOLCHAIN_BUILDROOT
bool "Buildroot toolchain"
+ depends on !BR2_avr32
config BR2_TOOLCHAIN_EXTERNAL
- bool "External toolchain"
+ bool "External binary toolchain"
+
+config BR2_TOOLCHAIN_EXTERNAL_SOURCE
+ bool "External source toolchain"
endchoice
+config BR2_TOOLCHAIN_SOURCE
+ bool
+ default y if !BR2_TOOLCHAIN_EXTERNAL
+ default n if BR2_TOOLCHAIN_EXTERNAL
+
source "target/device/Toolchain.in"
source "toolchain/Config.in.2"
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index d0546d457..7ca7a55ee 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -65,13 +65,13 @@ BINUTILS_TARGET_CONFIG_OPTIONS=--with-gmp="$(GMP_TARGET_DIR)"
BINUTILS_TARGET_CONFIG_OPTIONS+=--with-mpfr="$(MPFR_TARGET_DIR)"
endif
-ifeq ($(BR2_TOOLCHAIN_NORMAL),)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),)
BINUTILS_SITE:=$(VENDOR_SITE)
endif
BINUTILS_OFFICIAL_VERSION:=$(BINUTILS_VERSION)$(VENDOR_SUFFIX)$(VENDOR_BINUTILS_RELEASE)
-ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
BINUTILS_PATCH_DIR:=toolchain/binutils/$(BINUTILS_VERSION)
else
BINUTILS_PATCH_DIR:=$(VENDOR_PATCH_DIR)/binutils-$(BINUTILS_OFFICIAL_VERSION)
diff --git a/toolchain/external-toolchain/Config.in b/toolchain/external-toolchain/Config.in
index 197f06968..18da9795a 100644
--- a/toolchain/external-toolchain/Config.in
+++ b/toolchain/external-toolchain/Config.in
@@ -1,7 +1,8 @@
#
-menu "External Toolchain Options"
- depends on BR2_TOOLCHAIN_EXTERNAL
+if BR2_TOOLCHAIN_EXTERNAL
+comment "External Toolchain Options"
+
config BR2_TOOLCHAIN_EXTERNAL_LIB_C
string "The core C library from the external toolchain"
@@ -104,4 +105,4 @@ config BR2_TARGET_OPTIMIZATION
help
Optimizations to use when building for the target host.
-endmenu
+endif
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index bb34797be..0f9a9266a 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -33,7 +33,7 @@ endif
# redefine if using an external prepatched gcc source
-ifeq ($(BR2_TOOLCHAIN_NORMAL),)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),)
GCC_SITE:=$(VENDOR_SITE)
GCC_OFFICIAL_VER:=$(GCC_VERSION)$(VENDOR_SUFFIX)$(VENDOR_GCC_RELEASE)
endif
@@ -41,7 +41,7 @@ endif
GCC_SOURCE:=gcc-$(GCC_OFFICIAL_VER).tar.bz2
GCC_DIR:=$(TOOL_BUILD_DIR)/gcc-$(GCC_OFFICIAL_VER)
-ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
ifeq ($(GCC_SNAP_DATE),)
GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
else
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 7b6ceb032..3b2d1c03d 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -30,13 +30,13 @@ GCC_SITE:=ftp://sources.redhat.com/pub/gcc/snapshots/$(GCC_OFFICIAL_VER)
endif
# redefine if using an external prepatched gcc source
-ifeq ($(BR2_TOOLCHAIN_NORMAL),)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),)
GCC_SITE:=$(VENDOR_SITE)
GCC_OFFICIAL_VER:=$(GCC_VERSION)$(VENDOR_SUFFIX)$(VENDOR_GCC_RELEASE)
endif
# define patch location
-ifeq ($(BR2_TOOLCHAIN_NORMAL),y) # Normal toolchain
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y) # Normal toolchain
ifeq ($(GCC_SNAP_DATE),) # Not a snapshot
GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
else # Is a snapshot
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 6486f874b..e74090708 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -20,7 +20,7 @@ GDB_DIR:=$(TOOL_BUILD_DIR)/gdb-$(GDB_VERSION)
GDB_PATCH_DIR:=toolchain/gdb/$(GDB_VERSION)
else
-ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
GDB_SITE:=http://ftp.gnu.org/gnu/gdb
else
GDB_SITE:=$(VENDOR_SITE)
@@ -31,7 +31,7 @@ GDB_OFFICIAL_VERSION:=$(GDB_VERSION)$(VENDOR_SUFFIX)$(VENDOR_GDB_RELEASE)
GDB_SOURCE:=gdb-$(GDB_OFFICIAL_VERSION).tar.bz2
GDB_CAT:=$(BZCAT)
-ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
else
GDB_PATCH_DIR:=$(VENDOR_PATCH_DIR)/gdb-$(GDB_OFFICIAL_VERSION)
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 5a3e54845..1c10f1290 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -34,14 +34,14 @@ UCLIBC_VER:=0.9.28
endif
UCLIBC_SITE:=http://www.uclibc.org/downloads
-ifeq ($(BR2_TOOLCHAIN_NORMAL),)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),)
UCLIBC_SITE:=$(VENDOR_SITE)
endif
UCLIBC_OFFICIAL_VERSION:=$(UCLIBC_VER)$(VENDOR_SUFFIX)$(VENDOR_UCLIBC_RELEASE)
-ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
UCLIBC_PATCH_DIR:=toolchain/uClibc/
else
UCLIBC_PATCH_DIR:=$(VENDOR_PATCH_DIR)/uClibc-$(UCLIBC_OFFICIAL_VERSION)