summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2013-05-06 00:14:57 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-06 12:29:34 +0200
commitcccb01bf5947a7ea3a80cb14d680259e3a20d428 (patch)
tree6ff2f11c35d6c2a4b6f662a373d4454fa438bbc6 /toolchain
parentd451f3c0bb9efd97263b7f5e49c2fb5fe62f41dc (diff)
downloadbuildroot-novena-cccb01bf5947a7ea3a80cb14d680259e3a20d428.tar.gz
buildroot-novena-cccb01bf5947a7ea3a80cb14d680259e3a20d428.zip
toolchain/gcc: Enable --with-float for powerpc
Commit 8d929f4b ("toolchain/gcc: Only enable --with-float when it makes sense") restricted the --with-float use to only MIPS, ARM and SPARC, while it seems that powerpc needs it as well. Fixes the qemu_ppc_virtex_ml507_defconfig build. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 128b7abe6..959568f7a 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -66,7 +66,8 @@ endif
# Determine soft-float options
ifeq ($(BR2_SOFT_FLOAT),y)
# only mips*-*-*, arm*-*-* and sparc*-*-* accept --with-float
-ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el)$(BR2_sparc),y)
+# powerpc seems to be needing it as well
+ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el)$(BR2_powerpc)$(BR2_sparc),y)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
endif
ifeq ($(BR2_arm)$(BR2_armeb),y) # only set float-abi for arm