summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorPatrick Ziegler <patrick.ziegler@fh-kl.de>2013-06-08 11:14:21 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-11 00:06:30 +0200
commit9d5e6fa2fd4e48bdc0235f6bb902329b804b312d (patch)
tree5885c8f6f08a6f66045f13344dc78a9fabe67fe9 /toolchain
parentf3d6e6cfd7c024d16fb3d21f47e5b9aa241bfefa (diff)
downloadbuildroot-novena-9d5e6fa2fd4e48bdc0235f6bb902329b804b312d.tar.gz
buildroot-novena-9d5e6fa2fd4e48bdc0235f6bb902329b804b312d.zip
ext-toolchain-wrapper: force hash-style to 'both'
If ext-toolchain-wrapper was built with a gcc that uses hash-style 'gnu' by default, the resulting binary might be unusable on other systems. The error in this case is "Floating point exception". Using hash-style 'both' solves this issue. Signed-off-by: Patrick Ziegler <patrick.ziegler@fh-kl.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/ext-tool.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 30a49533a..430b2bc57 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -491,7 +491,9 @@ $(HOST_DIR)/usr/bin/ext-toolchain-wrapper: $(STAMP_DIR)/ext-toolchain-installed
;; \
esac; \
done ;
- $(HOSTCC) $(HOST_CFLAGS) $(TOOLCHAIN_EXTERNAL_WRAPPER_ARGS) -s \
+ # We use --hash-style=both to increase the compatibility of
+ # the generated binary with older platforms
+ $(HOSTCC) $(HOST_CFLAGS) $(TOOLCHAIN_EXTERNAL_WRAPPER_ARGS) -s -Wl,--hash-style=both \
toolchain/toolchain-external/ext-toolchain-wrapper.c -o $@
# 'uclibc' is the target to provide toolchain / staging dir