summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-12-02 17:19:40 -0800
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-02 17:19:40 -0800
commit8cdabd76950e227af088729c53c7f741a46bd9cc (patch)
tree86f11d84d46f9a5cc6be78b425b07bb58abb5d93 /toolchain
parent677d5068b955cf713b73d285e41ec8eedbda8e38 (diff)
parentc4fbc4202ea47829396bc446e84fd85153513974 (diff)
downloadbuildroot-novena-8cdabd76950e227af088729c53c7f741a46bd9cc.tar.gz
buildroot-novena-8cdabd76950e227af088729c53c7f741a46bd9cc.zip
Merge branch 'next'
Kickoff 2013.02 cycle
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/Config.in26
-rw-r--r--toolchain/toolchain-external/ext-tool.mk6
2 files changed, 18 insertions, 14 deletions
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index f04ced697..4fe605d86 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -3,8 +3,8 @@ if BR2_TOOLCHAIN_EXTERNAL
choice
prompt "Toolchain"
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
- bool "Linaro 2012.10"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11
+ bool "Linaro 2012.11"
depends on BR2_arm
depends on BR2_cortex_a8 || BR2_cortex_a9
select BR2_TOOLCHAIN_EXTERNAL_GLIBC
@@ -12,7 +12,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
select BR2_INSTALL_LIBSTDCPP
help
Linaro toolchain for the ARM architecture. It uses Linaro
- GCC 2012.10 (based on gcc 4.7), Linaro GDB 2012.10 (based on
+ GCC 2012.11 (based on gcc 4.7), Linaro GDB 2012.10 (based on
GDB 7.5), eglibc 2.15. It generates code that runs on all
Cortex-A profile devices, but tuned for the Cortex-A9. The
code generated is Thumb 2, with the hard floating point
@@ -20,8 +20,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
To use this toolchain, you must disable soft float usage.
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
- bool "Linaro 2012.09"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
+ bool "Linaro 2012.10"
depends on BR2_arm
depends on BR2_cortex_a8 || BR2_cortex_a9
select BR2_TOOLCHAIN_EXTERNAL_GLIBC
@@ -29,7 +29,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
select BR2_INSTALL_LIBSTDCPP
help
Linaro toolchain for the ARM architecture. It uses Linaro
- GCC 2012.09 (based on gcc 4.7), Linaro GDB 2012.09 (based on
+ GCC 2012.10 (based on gcc 4.7), Linaro GDB 2012.10 (based on
GDB 7.5), eglibc 2.15. It generates code that runs on all
Cortex-A profile devices, but tuned for the Cortex-A9. The
code generated is Thumb 2, with the hard floating point
@@ -37,8 +37,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
To use this toolchain, you must disable soft float usage.
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
- bool "Linaro 2012.08"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
+ bool "Linaro 2012.09"
depends on BR2_arm
depends on BR2_cortex_a8 || BR2_cortex_a9
select BR2_TOOLCHAIN_EXTERNAL_GLIBC
@@ -46,14 +46,18 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
select BR2_INSTALL_LIBSTDCPP
help
Linaro toolchain for the ARM architecture. It uses Linaro
- GCC 2012.08 (based on gcc 4.7), Linaro GDB 2012.06 (based on
- GDB 7.4), eglibc 2.15. It generates code that runs on all
+ GCC 2012.09 (based on gcc 4.7), Linaro GDB 2012.09 (based on
+ GDB 7.5), eglibc 2.15. It generates code that runs on all
Cortex-A profile devices, but tuned for the Cortex-A9. The
code generated is Thumb 2, with the hard floating point
calling convention, and uses the VFPv3-D16 FPU instructions.
To use this toolchain, you must disable soft float usage.
+comment "Linaro toolchains available for Cortex-A{8,9}"
+ depends on BR2_arm
+ depends on !BR2_cortex_a8 && !BR2_cortex_a9
+
config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
bool "Sourcery CodeBench ARM 2012.03"
depends on BR2_arm
@@ -624,9 +628,9 @@ config BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX
config BR2_TOOLCHAIN_EXTERNAL_PREFIX
string
- default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
+ default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 8ce0a8472..beba49fff 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -184,15 +184,15 @@ TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.09-70-arm-none-linux-gnueabi-i686-pc-linux-gn
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203),y)
TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
TOOLCHAIN_EXTERNAL_SOURCE=arm-2012.03-57-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08),y)
-TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.08/+download/
-TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.08-20120827_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09),y)
TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.09/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.09-20120921_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10),y)
TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.10/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.10-20121022_linux.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11),y)
+TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.11/+download/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.11-20121123_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44),y)
TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package7401/public/mips-linux-gnu/
TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2