summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-05-26 12:08:14 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-27 23:51:05 +0200
commit517de29c523cd3561e723228a50aa414d3dc3fe1 (patch)
tree8d5824d540a5d4efdad7268f57b03c29e625482c /toolchain
parent85e3090a92e13b7afc426cb2d9189bbe8d2adaf4 (diff)
downloadbuildroot-novena-517de29c523cd3561e723228a50aa414d3dc3fe1.tar.gz
buildroot-novena-517de29c523cd3561e723228a50aa414d3dc3fe1.zip
gcc: fix gcc 4.8 build when thread support is disabled
When thread support is disabled, the libitm and libatomic libraries from gcc should be disabled, otherwise, the build of gcc fails. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 21679ef17..5be26c44c 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -203,7 +203,7 @@ GCC_TLS:=--disable-tls
endif
ifeq ($(BR2_PTHREADS_NONE),y)
-THREADS:=--disable-threads
+THREADS:=--disable-threads --disable-libitm --disable-libatomic
else
THREADS:=--enable-threads
endif