summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-10-23 09:49:56 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-10-23 09:49:56 +0000
commit3536c2f9192eec9ac8266423b1b67982ce1495c6 (patch)
treef5a311f1467e60b8645993345cc23439e92e1e79 /toolchain
parent79db2c698986554e537e01f9c784ad6019cb8a5c (diff)
downloadbuildroot-novena-3536c2f9192eec9ac8266423b1b67982ce1495c6.tar.gz
buildroot-novena-3536c2f9192eec9ac8266423b1b67982ce1495c6.zip
Ensure AVR32 FPU config is always correct
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in.22
-rw-r--r--toolchain/gcc/Makefile.in17
2 files changed, 10 insertions, 9 deletions
diff --git a/toolchain/Config.in.2 b/toolchain/Config.in.2
index d3a1a1945..244fcf108 100644
--- a/toolchain/Config.in.2
+++ b/toolchain/Config.in.2
@@ -48,7 +48,7 @@ config BR2_USE_WCHAR
config BR2_SOFT_FLOAT
bool "Use software floating point by default"
default n
- depends on BR2_arm || BR2_armeb || BR2_mips || BR2_mipsel || BR2_powerpc
+ depends on BR2_arm || BR2_armeb || BR2_avr32 || BR2_mips || BR2_mipsel || BR2_powerpc
help
If your target CPU does not have a Floating Point Unit (FPU) or a
kernel FPU emulator, but you still wish to support floating point
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 99b3e27ce..822de1c13 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -11,14 +11,6 @@ TARGET_OPTIMIZATION:=$(strip $(subst ",, $(BR2_TARGET_OPTIMIZATION)))
EXTRA_GCC_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_GCC_CONFIG_OPTIONS)))
#"))
-# AVR32 GCC configuration
-ifeq ($(strip $(BR2_avr32)),y)
-EXTRA_GCC_CONFIG_OPTIONS+=--disable-libmudflap
-EXTRA_GCC_CONFIG_OPTIONS+=--disable-libssp
-EXTRA_GCC_CONFIG_OPTIONS+=--with-build-time-tools=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin \
-#EXTRA_GCC_CONFIG_OPTIONS+=--with-as=$(TARGET_CROSS)as
-endif
-
ifeq ($(strip $(subst ",, $(BR2_GCC_IS_SNAP))),y)
#"))
GCC_SNAP_DATE:=$(strip $(subst ",, $(BR2_GCC_SNAP_DATE)))
@@ -71,6 +63,15 @@ GCC_WITH_ABI:=--with-abi=$(BR2_GCC_TARGET_ABI)
endif
endif
+# AVR32 GCC configuration
+ifeq ($(strip $(BR2_avr32)),y)
+EXTRA_GCC_CONFIG_OPTIONS+=--disable-libmudflap
+SOFT_FLOAT_CONFIG_OPTION:=
+EXTRA_GCC_CONFIG_OPTIONS+=--disable-libssp
+EXTRA_GCC_CONFIG_OPTIONS+=--with-build-time-tools=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin \
+#EXTRA_GCC_CONFIG_OPTIONS+=--with-as=$(TARGET_CROSS)as
+endif
+
TARGET_GCC_FLAGS= CFLAGS_FOR_TARGET="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \