summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorIvan Kuten <ivan.kuten@promwad.com>2007-11-15 10:16:55 +0000
committerIvan Kuten <ivan.kuten@promwad.com>2007-11-15 10:16:55 +0000
commit06510069f8690f38a95a7bf3744b7f3fe56ba6e0 (patch)
tree197bff3c603e76e29b9c55c3b3a4d126d526f802 /toolchain
parent94c236419b3fbb01ee4c4d96051e65449c40e13d (diff)
downloadbuildroot-novena-06510069f8690f38a95a7bf3744b7f3fe56ba6e0.tar.gz
buildroot-novena-06510069f8690f38a95a7bf3744b7f3fe56ba6e0.zip
install ldconfig stuff only if it was built, fix for systems without shared libraries support (nios2)
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/uclibc.mk14
1 files changed, 9 insertions, 5 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 9ce47289a..ebed4a03a 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -450,11 +450,15 @@ endif
PREFIX=$(STAGING_DIR) \
HOSTCC="$(HOSTCC)" \
hostutils
- install -c $(UCLIBC_DIR)/utils/ldd.host $(STAGING_DIR)/usr/bin/ldd
- ln -sf ldd $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-ldd
- install -c $(UCLIBC_DIR)/utils/ldconfig.host $(STAGING_DIR)/usr/bin/ldconfig
- ln -sf ldconfig $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-ldconfig
- ln -sf ldconfig $(STAGING_DIR)/usr/bin/$(GNU_TARGET_NAME)-ldconfig
+ if [ -f $(UCLIBC_DIR)/utils/ldd.host ]; then \
+ install -c $(UCLIBC_DIR)/utils/ldd.host $(STAGING_DIR)/usr/bin/ldd; \
+ ln -sf ldd $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-ldd; \
+ fi
+ if [ -f $(UCLIBC_DIR)/utils/ldconfig.host ]; then \
+ install -c $(UCLIBC_DIR)/utils/ldconfig.host $(STAGING_DIR)/usr/bin/ldconfig; \
+ ln -sf ldconfig $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-ldconfig; \
+ ln -sf ldconfig $(STAGING_DIR)/usr/bin/$(GNU_TARGET_NAME)-ldconfig; \
+ fi
touch -c $@
ifneq ($(TARGET_DIR),)